Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

/Qpar-threshold not recognised

dehvidc1
Beginner
150 Views
I'm building with Intel C++ under MSVS2008. The Intel C++ compiler says:

1>Compiling with Intel C++ Compiler 11.1.071 [IA-32]... (Intel C++ Environment)

1>icl: command line remark #10148: option '-Qpar-threshold' not supported

I have /Qparallel set.

Any suggestions?

Thanks

David

0 Kudos
3 Replies
TimP
Black Belt
150 Views
Did you spell it in accordance with documentation, e.g. /Qpar-threshold50 ?
Yes, it's somewhat surprising there is no "=".
This is not to say that I had much success with the option on that compiler version. By that time, most of the development effort was going into Parallel Studio.
dehvidc1
Beginner
150 Views
Yes. I followed the spelling as per the examples Intel provided. It defaults to 100 if you don't supply a numeric

Regards

David
Milind_Kulkarni__Int
New Contributor II
150 Views

You can do that with this command-line:--

icl -c /Qpar-threshold:99 /Qparallel test.cpp

This option does not work for Parallel Studio C++ compilers, but will work for Professional C++ compilers. See if you are using Parallel Studio compiler.

Reply