Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
54 Views

Re: How to enable SSE in Debian??

As i am a beginner to use the xmm registers i a facing some problem when compiling a C programm embedded with sse instructions. I got an error as "SSE not enabled". I am using a Debian Os which has a GCC compiler of 4.1.2 version. Should we include the headers like xmmintrin.h,mmintrin.h,...etc. Please help me with some suggetions.Thank you in advance
0 Kudos
3 Replies
Highlighted
Black Belt
54 Views

If you are using the 32-bit linux compiler, you must include an SSE option, such as -xW, as well as including headers to define any SSE intrinsics you may be using.
0 Kudos
Highlighted
Beginner
54 Views

How should we include the SSE option -xW??Can you please explain me in detail or can you suggest me some sites for getting a clear understanding of the above.Thank you.
0 Kudos
Highlighted
Valued Contributor I
54 Views

First you need to clarify your "SSE not enabled" error. What program or development tool is giving you that error? Is that the exact wording?

Then you need to determine which CPU you have in your computer. You do that by typing

cat /proc/cpuinfo

If that CPU supports SSE, you need to check whether operating system kernel was compiled with SSE support. Most new linux kernels are compiled with that support enabled but you should check your kernel configuration just to be sure.

If your CPU doesn't support SSE or your kernel is not configured properly then you should still be able to develop the code but not to test it on that computer.

To enable Intel compiler to generate SSE instructions use -QxK command line switch in addition to other compilation switches you are using. If you need command line switches for gcc compiler please consult the appropriate documentation for gcc.

Perhaps you are having problems compiling C or C++ code which contains inline assembler with SSE instructions? In that case I am afraid I cannot help you further.

0 Kudos