Community
cancel
Showing results for 
Search instead for 
Did you mean: 
76 Views

Running application on the command line v. within Visual Studio 2019

Hello,

I'm using Intel Parallel Studio XE 2019 with the latest updates.  

I have an application that uses tbb, mkl and openmp. If I build this application in release mode, I can run it from within visual studio as well as from powershell (and the VS command line).

 

However, if I build it in debug mode, it runs fine from within VS but not on the command prompt. I get no output at all. Any ideas what I may be missing? 

Things that I've tried:

  1. I have added the directory containing tbb.dll to the path (in my case it is C:\Program Files (x86)\Common Files\Intel\OpenCL\bin\x86\tbb). I also copied tbb.dll to the Debug directory (that contains the exe file), but no difference
  2. In project properties -> C/C++ -> Code Generation: the runtime library has four options (see below). For a Debug build, I have tried both /MTd and /MDd), but get the same behavior. /MT and /MD don't link since external symbols aren't found. For a Release buil, #1 and 2 work, #3 and 4 give the same behavior (no output)
    1. Multi-threaded (/MT)
    2. Multi-threaded debug (/MTd)
    3. Multi-threaded DLL(/MD)
    4. Multi-threaded debug DLL (/MDd)

 

Any idea what is going on? Are there any tools / commands I can use to get more information?

A related question:

I find tbb.dll, tbbmalloc.dll and tbb_preview.dll, but not their debug versions. When I try to run this application in Intel Advisor, I get a message saying "tbb_debug.lib" not found. Is my installation missing something?

 

Many thanks,

Shrirang

0 Kudos
1 Reply
Viet_H_Intel
Moderator
76 Views

What VS2019 version you have?

Reply