Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
7679 Discussions

Slow compile times with Composer XE SP1

Daniel_F_6
Beginner
155 Views
I recently upgraded from Composer XE Update 1 to SP1 on a 64-bit Ubuntu 11.04 box. Prior to the upgrade, my build process took <1 minute. Now it hangs up on one file in particular and takes >7 minutes to complete. This file is kind of large ~1500 lines, includes several other files, and makes use of templates. I haven't changed anything about my build process. The only compiler flags I use are -O3 and -openmp. Any thoughts out there on this problem? Perhaps I'm using a 'feature' that is turned on by default now that wasn't previously?
Thanks.
0 Kudos
3 Replies
IDZ_A_Intel
Employee
155 Views
Daniel,
There are no fundamental changes from Update 1 to SP1. So we would need a reproducer or the full project if possible.If you can share something we should follow uponIntel Premier Support. Pls. advise.
Regards,
Hubert.
Daniel_F_6
Beginner
155 Views
Thanks. I'll see what I can come up with for a reproducer (full project can't be sent). I should also add that removing '-O3' makes the compile time very reasonable (a few seconds)...of course this is expected.
TimP
Black Belt
155 Views
You might be able to find the location in your source code of a more aggressive optimization effort in the later compiler by comparing the opt-report-file output (preferably between the compiler versions, both with the same options, but possibly also between -O2 and -O3 with ther later compiler).
I've found in a few cases that the later compilers favor a switch to CEAN array notation in order to target the optimizations performed. I agree with the advice to submit a reproducer to see if the newer compiler is mis-targeting its efforts.
It's also possible that a more aggressive optimization has run into a shortage of RAM on your installation. In that case, cutting it down might make your problem go away.
Reply