Community
cancel
Showing results for 
Search instead for 
Did you mean: 
samuel_p_
Beginner
856 Views

Slow license check

Hi,

Here i have the same behaviour: when i try to compile the compiler tooks a long time verifying the license.

Is there abybody that has found a solution for this error.

 

Thanks, Sam.

0 Kudos
61 Replies
samuel_p_
Beginner
536 Views

Hi,

An extra information:

The problem only occours when we use the 15.01 version of Intel compiler. The 14.0.2 version runs smoothly and it took a short time to execute.

Intel 15.01:

$ time icc -V
Intel(R) C Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 15.0.5.223 Build 20150805
Copyright (C) 1985-2015 Intel Corporation.  All rights reserved.


real    0m26.389s
user    0m0.012s
sys    0m0.028s

Intel 14.0.2

time icc -V
Intel(R) C Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 14.0.2.144 Build 20140120
Copyright (C) 1985-2014 Intel Corporation.  All rights reserved.


real    0m0.927s
user    0m0.008s
sys    0m0.019s

 

Any help will be very useful.

Cheers!, Sam.

Steven_L_Intel1
Employee
536 Views

Samuel, There are several possible reasons for this behavior, with different solutions. Do you have more than one license server defined in your license file(s)? If so, do all of them have the current Parallel Studio XE license?

samuel_p_
Beginner
536 Views

Hi Steve, thanks for your reply.

We have only one license server defined. so any help will be very helpful.

Steven_L_Intel1
Employee
536 Views

Samuel, since you are reporting using the Intel C++ compiler, I am going to move your question to a separate thread in the C++ support forum.

samuel_p_
Beginner
536 Views

Hi, the problems occours with the ifort compiler too:

# time ifort -V
Intel(R) Fortran Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 15.0.5.223 Build 20150805
Copyright (C) 1985-2015 Intel Corporation.  All rights reserved.


real    0m25.685s
user    0m0.005s
sys    0m0.020s

So, the problem (i think) is with the license server but only coours with the 15.01 version.

Cheers!

samuel_p_
Beginner
536 Views

This behaviour only occours in Intel 2015 version. If we use intel 2014 there is no problem and the compiler is really fast.

Cheers.

Kittur_G_Intel
Employee
536 Views

Hi Samuel,
Can you ensure that the INTEL_LICENSE_FILE variable is set to the correct license file and try? The link at: https://software.intel.com/en-us/articles/how-to-set-intel-license-file-environment-variable gives the info. Make sure to set the full path including the .lic suffix, thanks.
_Kittur

samuel_p_
Beginner
536 Views

Hi, thanks for the reply.

We've already tried that with no success.

Thanks,

Kittur_G_Intel
Employee
536 Views

Thanks Samuel. I've sent you a private email asking for more debug info which you can attach there in your response to that email for further investigation, appreciate much.
_Kittur

samuel_p_
Beginner
536 Views

Hi Kittur.

¿Any news about the issue?.

Here we detected a lot of intelremotemond processes running and we kill'em all and restart the flex license manager at license server, but the problem still persist.

Cheers!

Kittur_G_Intel
Employee
536 Views

Hi Sam,
Pardon the delay as I'd to wait for a response from my peer in another zone and finish some investigation. Appreciate your patience through this.  Well, could you please REMOVE unused license file from any of  these locations below:

1.  /home/apps/intel/15.0.1/licenses/USE_SERVER.lic
2.  /home/apps/intel/15.0.1/licenses/idl.lic
3.  /home/apps/intel/15.0.1/composer_xe_2015.5.223/bin/intel64/../../Licenses
4.  /home/leumas/Licenses
5.  /opt/intel/licenses
6.  /Users/Shared/Library/Application Support/Intel/Licenses
7.  /home/apps/intel/15.0.1/composer_xe_2015.5.223/bin/intel64/USE_SERVER.lic

Try the above and see if it resolves your issue and let me know.,

Also, if there is any invalid server indicated in an unused license file, the licensing client will still check that and waits for a timeout.
And if it is not the root cause (no unused license file), then can you please upgrade the license server version to version 2.3?

Thanks,
Kittur

samuel_p_
Beginner
536 Views

Hi Kittur:

Thanks for the reply.

We have removed all the unused licenses and only left the used one. Also we check that the license point to the correct server, but still we have the same problem.

We updated the license server version to the last one: 2.3, and still have the issue.

Thanks for the reply, again!

Kittur_G_Intel
Employee
536 Views

That's interesting Samuel. I've let the license issues support team on your feedback and will update you as soon as I've an update. Appreciate your patience till then.

_Regards,
Kittur

Nathan_D_1
Beginner
536 Views

Hello, 

To whom it may concern, we are also having the same problem. We are upgrading from Intel FORTRAN 2013 to XE2016 Update 1. I have upgraded the license and ensured we have cleared all the license variables and areas you have mentioned above. However when we run ifort.exe from 2016, we get an average compile time of ~30secs per file. When i run the same files through the ifort.exe compiler from 2013, after the initial checkout of a license, we get an average compile time of ~0.2 secs. 

Attempt    2013             2016
---------------------------------------------
1            00:03.27       0:40.59
2            00:00.18       0:31.21
3            00:00.15       0:31.28

Obviously this is a huge performance hit to the point we can't run our required builds. We have rolled back to using the 2013 compilers but I am hoping there is a fix for this soon.

We are running Windows Server 2012 as our license server. Please let me know if you would like any information or tests run for more information on this from us. 

samuel_p_
Beginner
536 Views

Hi,

Now that Nathan comment, we did an Intel course and installed the 2016 version, for 3 weeks (temporary license), after that Intel 2015 begun to validate the license slowly.

This is just for the record, maybe intel 2016 did something.

Cheers.

Kittur_G_Intel
Employee
536 Views

Thanks Samuel/Nathan for the info. I've passed on the same to the license group and will touch base with you as soon as I've some update after their investigation, thanks.
_Kittur

Kittur_G_Intel
Employee
536 Views

Hi Samuel,
Can you please set the environment variable FLEXLM_DIAGNOSTICS=3 on the product system and attach the log file output. You can send me a private email like before with the info. This is needed for further investigation. Again, appreciate your patience, thank.

_Kittur

Kittur_G_Intel
Employee
536 Views

Hi Samuel,
Any update? Can you please provide the log with the FLEXLM_DIAGNOSTICS=3 setting that I mentioned in my earlier response so our developers can investigate further? As always, appreciate your patience and understanding through this as this looks like an isolated incident, thanks.

_Kittur

Kittur_G_Intel
Employee
536 Views

Hi Nathan,
Looks like Samuel is busy or may be on vacation?  Can you try setting the environment variable suggested in my previous communication and attach the log? Thanks much for your help.
_Kittur

samuel_p_
Beginner
255 Views

Hi!

i'm pasting my previous answer (by email)

Hi Kittur.Here is the output:[leumas@leftraru1 ~]$ icc -vCheckout succeeded: CCompL/4EE3B5616E29License file: /opt/intel/licenses/master1-flex.licLicense Server: 28518@master1icc version 15.0.4 (gcc version 4.8.5 compatibility)[leumas@leftraru1 ~]$Thanks a lot for your assistance, we appreciate it.Regards,

 

Thanks

Reply