Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Wonsik_Kim
Beginner
85 Views

Source file path recorded in object code

Hi,

I am building a dll file with OpenMP directives to parallelize the code. I examined the dll file and found my source file path reside in the dll file as follows:

104B1190: 94 11 4B 10 3B 44 3A 5C 50 72 6F 6A 65 63 74 73 ..K.;D:\\Projects
104B11A0: 5C XX XX XX XX XX XX 5C 73 72 63 5C 33 72 64 20 \\XXXXXX\\src\\3rd
104B11B0: 50 61 72 74 79 5C 69 70 70 5F 73 61 6D 70 6C 65 Party\\ipp_sample
104B11C0: 73 5C 61 75 64 69 6F 2D 76 69 64 65 6F 2D 63 6F s\\audio-video-co
104B11D0: 64 65 63 73 5C 63 6F 64 65 63 5C 68 32 36 34 5F decs\\codec\\h264_
104B11E0: 65 6E 63 5C 69 6E 63 6C 75 64 65 5C 75 6D 63 5F enc\\include\\umc_
104B11F0: 68 32 36 34 5F 67 65 6E 5F 65 6E 63 5F 74 6D 70 h264_gen_enc_tmp
104B1200: 6C 2E 63 70 70 2E 68 3B 3F 48 32 36 34 43 6F 72 l.cpp.h;?H264Cor
104B1210: 65 45 6E 63 6F 64 65 72 5F 43 6F 6D 70 72 65 73 eEncoder_Compres
104B1220: 73 46 72 61 6D 65 5F 38 75 31 36 73 2E 2E 34 31 sFrame_8u16s..41
104B1230: 40 55 4D 43 5F 48 32 36 34 5F 45 4E 43 4F 44 45 @UMC_H264_ENCODE
104B1240: 52 40 40 59 41 48 50 41 58 41 41 57 34 45 6E 75 R@@YAHPAXAAW4Enu
104B1250: 6D 50 69 63 43 6F 64 54 79 70 65 40 31 40 41 41 mPicCodType@1@AA
104B1260: 57 34 45 6E 75 6D 50 69 63 43 6C 61 73 73 40 31 W4EnumPicClass@1
104B1270: 40 50 41 56 4D 65 64 69 61 44 61 74 61 40 55 4D @PAVMediaData@UM
104B1280: 43 40 40 40 5A 2E 4A 3B 35 39 34 3B 35 39 34 3B C@@@Z.J;594;594;

So the question is, how can I remove this information from my dll file? It seems that the numbers at the end of the string is related to OpenMP parallelized portion of the code.

Thanks in advance,

Wonsik.
0 Kudos
7 Replies
Judith_W_Intel
Employee
85 Views


Can you trydisabling this flag (i.e put the dash at the end):

/Qparallel-source-info[-]
enable(DEFAULT)/disable the emission of source location information
for parallel code generation with OpenMP and auto-parallelization

Judy
Wonsik_Kim
Beginner
85 Views

Thank you for the suggestion. I tried setting the option and the compiler emits the following warning, and the result seems to be unchanged.

1>Compiling with Intel C++ 11.1.065 [IA-32]... (Intel C++ Environment)
1>warning #13000: could not open message catalog file:
1>icl: command line warning #10156: ignoring option '/Qparallel'; no argument required

My compiler options is as folows:

/c /Ob2 /Oi /Ot /Qip /GA /I "include" /I "C:\Program Files\Intel\IPP\6.1.6.056\ia32\..\ia32\include" /I "..\..\core\umc\include" /I "..\..\core\vm\include" /I "..\..\core\vm_plus\include" /I "..\..\codec\common\include" /I "..\..\codec\color_space_converter\include" /D "WIN32" /D "NDEBUG" /D "_LIB" /D "_MBCS" /EHa /MT /GS- /arch:IA32 /fp:fast /Fo"..\..\_bin\Win32\Release\h264_enc_opt/" /W4 /nologo /Qopenmp /Quse-intel-optimized-headers /Qparallel-source-info- /QaxSSE2,SSE3,SSSE3,SSE4.1,SSE4.2

Any suggestions on turning on/off certain options to get it work?

Thanks,
Wonsik.

ps. I am building my application on Visual Studio 2008 IDE.
JenniferJ
Moderator
85 Views

This is because of the /Qopenmp option.

This is a known issue and is recorded as DPD200119058. It is not fixed. When there is a fix, we will post a news here.

thanks,
Jennifer
jimdempseyatthecove
Black Belt
85 Views

Wonsik,

Look in the MS linker options. There may be an option to strip "comments" from the execuitable/dll.
If the above is in a comment section, then it will strip, if not, then it is stuck in there.

Plan B would be to write a utility to search the DLL for offending textand overstrike the text with something to obscure the information. However, read your software license(s) for restrictions against such modifications.

Jim Dempsey
TimP
Black Belt
85 Views

The information is placed there for convenience in profiling. If you are concerned about others finding your source code, you might set up a build procedure which compiles in a temporary location, then removes it. Your security barriers must not be high if this information would facilitate such a search.
Wonsik_Kim
Beginner
85 Views

Well, if it's a not-yet-fixed issue of the compiler, I guess I would just wait until the issue is fixed. Thank you everyone!
JenniferJ
Moderator
85 Views

I do not see any path info being included in the final .exe any more with 15.0, but the symbol "_main" is in the .exe though.

But if adding "/Qparallel-source-info-", the symbol "_main" is not emitted as well.

I only tried with simple test cases, please check it out and let me know if it works for you using the option above.

Thanks,

Jennifer

Reply