Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Curtis_H_
Beginner
57 Views

Switching back to vc++: Cannot get rid of /fast option

I've been experimenting with the Intel compiler for the past few weeks, and decided to go back to the VC++ compiler.  I right clicked on the solution and selected "use vc++" compiler.  Tried to build, and got a bunch of warnings about "ignoring unknown option /fast".  I uninstalled the Intel compiler, completely blew away the development directly, got latest from source control, and the warnings are still there.  I searched all of the files in the dev directory (including property sheets and project settings) for the /dev flag.  Nothing. 

Where else could the setting be coming from?  None of the other command line options that I had entered are showing up, just /fast.

0 Kudos
2 Replies
Curtis_H_
Beginner
57 Views

It was lurking in the Microsoft.Cpp.Win32.user property sheet.  I never altered that property sheet.  All solution wide changes were done through a dedicated property sheet.

jimdempseyatthecove
Black Belt
57 Views

Let me guess, did you have something like one Solution with two Builds (Debug and Release), (possibly x2 platforms Win32 and x64). You configured for ICC, then added an additional option on the command line options in the C++ compiler Advanced property sheet. Worked fine until some time later, when you switched back to MSVC.

What you should have done is create 4 builds: DebugICC, ReleaseICC, DebugMSVC, ReleaseMSVC (possibly x2 platforms Win32 and x64).
Or, not add additional options unique to one compiler on the Advanced property sheet.

Jim Dempsey

Reply