Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
7646 Discussions

Trying to compile quake 3 source witn XE - getting error

TyMac
Beginner
153 Views
Can somebody tell me what this error means I'm getting?


make  targets B=debugi386-glibc CFLAGS="-pipe -fsigned-char -g  -Wall -Werror -DNO_MOUSEGRAB -O"
make[1]: Entering directory `/usr/src/quake3-1.32b/code/unix'
icc -pipe -fsigned-char -g  -Wall -Werror -DNO_MOUSEGRAB -O -o debugi386-glibc/client/cl_cgame.o -c ..//client/cl_cgame.c   
..//client/cl_cgame.c(448): error #188: enumerated type mixed with another type
  		return FS_FOpenFileByMode( VMA(1), VMA(2), args[3] );
  		                                           ^

..//client/cl_cgame.c(516): error #188: enumerated type mixed with another type
  		S_ClearLoopingSounds(args[1]);
  		                     ^

..//client/cl_cgame.c(534): error #188: enumerated type mixed with another type
  		return S_RegisterSound( VMA(1), args[2] );
  		                                ^

..//client/cl_cgame.c(626): error #810: conversion from "char *" to "int" may lose significant bits
  		return (int)strncpy( VMA(1), VMA(2), args[3] );
  		       ^

..//client/cl_cgame.c(737): error #188: enumerated type mixed with another type
  		interpret = Cvar_VariableValue( "vm_cgame" );
  		          ^

..//client/cl_cgame.c(784): error #188: enumerated type mixed with another type
  	return VM_Call( cgvm, CG_CONSOLE_COMMAND );
  	       ^

compilation aborted for ..//client/cl_cgame.c (code 2)
make[1]: *** [debugi386-glibc/client/cl_cgame.o] Error 2
make[1]: Leaving directory `/usr/src/quake3-1.32b/code/unix'
make: *** [build_debug] Error 2



0 Kudos
2 Replies
TimP
Black Belt
153 Views
You set -Werror, which turns warnings into fatal errors. Among your options may be to fix the source code, drop the -Werror option, turn off the specific error checks, or use an old gcc which didn't make these syntax checks.
TyMac
Beginner
153 Views
Taking Werror out of the make file appears to have fixed the issue thanks!
Reply