Intel® C++ Compiler
Community support and assistance for creating C++ code that runs on platforms based on Intel® processors.
7932 Discussions

Unable to install c++ eclipse extension 2015

New Contributor I


I am trying to install intel C++ compiler 15 plugin into eclipse. I followed instalation instruction in

In fact in past I already installed same plugin on same system from composer 2013 without problems. I run compilervars script in console and then run eclipse with vm set to jdk 1.8 I am able to add local eclipse repository for composer xe 2015. When packages loads the first strange thing is the documentutation package is in chinese (at least I think it is chinese).


After successfull instalation eclipse restarts but there is no "intel" menu as in 2013 version. Moreover in help->help content there is no help from intel. I think instalation was completed because I see installed packages and intel c++ 15 resources link


Curent screenshots are from latest eclipse kepler with CDT 8.3. I Also tried CDT 8.2 with Kepler, CDT 8.1 with juno, CDT 8.5 with luna. Also tried jdk 1.7 and jdk 1.8, jdk 1.6 for juno. All configurations resulted in same error when I tried to create new C++ project.   (see output from console)


~/Downloads> source /data/development/intel/bin/ intel64
~/Downloads> export LANG=en_US
~/Downloads> ./eclipse/eclipse -vm jdk1.7.0_71/bin/java
java.lang.Exception: Exception in client
    at org.eclipse.core.runtime.SafeRunner.handleException(
    at org.eclipse.cdt.managedbuilder.internal.core.ToolChain.isSupported(
    at org.eclipse.cdt.managedbuilder.ui.wizards.AbstractCWizard.isValid(
    at org.eclipse.cdt.managedbuilder.ui.wizards.ManagedBuildWizard.createItems(
    at org.eclipse.cdt.ui.wizards.CDTMainWizardPage.updateData(
    at org.eclipse.cdt.ui.wizards.CDTMainWizardPage.createControl(
    at org.eclipse.jface.wizard.Wizard.createPageControls(
    at org.eclipse.jface.wizard.WizardDialog.createPageControls(
    at org.eclipse.jface.wizard.WizardDialog.createContents(
    at org.eclipse.jface.window.Window.create(
    at org.eclipse.jface.dialogs.Dialog.create(
    at org.eclipse.jface.action.Action.runWithEvent(
    at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(
    at org.eclipse.jface.action.ActionContributionItem.access$2(
    at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(
    at org.eclipse.swt.widgets.EventTable.sendEvent(
    at org.eclipse.swt.widgets.Widget.sendEvent(
    at org.eclipse.swt.widgets.Display.runDeferredEvents(
    at org.eclipse.swt.widgets.Display.readAndDispatch(
    at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(
    at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(
    at org.eclipse.ui.internal.Workbench$
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(
    at org.eclipse.equinox.launcher.Main.invokeFramework(
    at org.eclipse.equinox.launcher.Main.basicRun(
    at org.eclipse.equinox.launcher.Main.main(
Caused by: java.lang.NullPointerException
    ... 47 more

I do not know what I am doing wrong. Plugin from composer xe 2013 is working correctly. Composer xe 2015 is installed in latest version. 

Thank you for advice,


0 Kudos
0 Replies