Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
165 Views

Unresolved references in MSVCRT.lib with Visual Studio 2015 RC

I installed Intel Parallel Studio XE 2016 Beta Update 1 with Visual Studio Community 2015 RC and I'm getting unresolved references in MSVCRT.lib when I try to build a default Win32 console project in x64 mode:

1>ipo: : warning #11021: unresolved __vcrt_initialize
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __vcrt_uninitialize
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __vcrt_uninitialize_critical
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __vcrt_thread_attach
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __vcrt_thread_detach
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved _is_c_termination_complete
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __acrt_initialize
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __acrt_uninitialize
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __acrt_uninitialize_critical
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __acrt_thread_attach
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : warning #11021: unresolved __acrt_thread_detach
1>          Referenced in MSVCRT.lib(utility.obj)
1>ipo: : error #11023: Not all components required for linking are present on command line

All project settings are defaults set by project wizard. I installed only 64-bit target tools.

 

0 Kudos
3 Replies
Highlighted
New Contributor I
165 Views

I found an answer. Configuration Properties -> General -> Use of MFC has to be changed from default "Use Standard Windows Libraries" to "Use MFC in a Shared DLL".

EDIT: Unfortunately this doesn't work, so I'm still looking for a solution.

0 Kudos
Highlighted
165 Views

Hi Paul,

According to beta update 1 release notes, beta update 1 doesn't support VS 2015 yet.  IPS XE 2015 Update 4 was posted yesterday.  Support for VS 2015 has been added to it.

Thanks.

0 Kudos
Highlighted
New Contributor I
165 Views

Hi Feilong,

The reason I went for VS 2015 integration was that such an option was presented during installation procedure. Additionally, a few sample projects provided with IPS XE 2016 build with VS 2015 just fine. I will just use one of the sample projects for now.

Thank you.

0 Kudos