Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
7744 Discussions

VS 2005 Command Line Support in Intel C++ Compiler 9.0

Steven_L_Intel1
Employee
289 Views
As of version w_cc_c_9.0.030, the compiler installation will automatically detect Visual Studio 2005, including Express Edition, and offer to install command-line integration for it. So, as of this version, you don't have to manually edit the installed files.

If you are an Express Edition user, we recommend that you also download and install the Microsoft Platform SDK before installing the compiler so that you have access to the Win32 API libraries which are not provided with VS2005 Express Edition.

Please note that Developer Studio integration into VS2005 is NOT supported in Intel C++ Compiler 9.0.
0 Kudos
7 Replies
darietti7
Beginner
289 Views
On wich version of the Intel C++ Compileris the integration with VS2005 C++ IDEplanned?
Steven_L_Intel1
Employee
289 Views
"The next one" as in version, not just maintenance update. Look for it in mid-May. Please note that, due to Microsoft restrictions, IDE integration for VS2005 Express Edition will not be provided. The Standard Edition or higher will be required for IDE support.
chris3
Beginner
289 Views
Will this work on EM64T (host+target) too?

Thanks-
JenniferJ
Moderator
289 Views

Yes. The next release (9.1) willsupport the Intel EM64T compiler within VS2005 IDE (standard edition or above).

Jennifer

chris3
Beginner
289 Views
Thanks for the response, its good to hear that 9.1 will support it, but I was interested in the support in 9.0.033.

To be more specific, will the command line support for building EM64T applications available in version 9.0.033 be compatible with VS 2005 C++ headers and libraries?

Currently, I think the EM64T command line requires the use of the Windows Server 2003 Platform SDK (which is old and pre-ISO C++).

Thanks,
Chris
JenniferJ
Moderator
290 Views

Yes. The pkg is w_cc_c_9.0.030.

You may need to update the ...9.0EM64TBiniclvars.bat to call VC2005's vcvars.bat like below to setup the environment correctly:

call "C:Program FilesMicrosoft Visual Studio 8VCvcvarsall" x86_amd64

Jennifer

chris3
Beginner
290 Views
Thanks, I gave it a try and that seems to work great in 9.0.030.

Now if only there was a way to turn off the "deprecated function" warning, the /wd1478 switch doesn't seem to have any effect...

Thanks,
Chris
Reply