Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bruno_A_1
Beginner
177 Views

VS 2013 update 4 and Intel® Parallel Studio XE Professional Edition for C++ Windows 2015

When installing, I get msg regarding lack of x64 VS2012. I am installing on a system with fresh VS2013 update 4 + CUDA. Unfortunately, I cannot compile anything. I get this, even with a brand new solution.

C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\x64\PlatformToolsets\v120\ImportBefore\Intel.Libs.IPP.v120.targets(41,32): A numeric comparison was attempted on "$(IPPMajorVersion)" that evaluates to "" instead of a number, in condition "$(IPPMajorVersion) > 7 AND ('%(RuntimeLibrary)' == 'MultiThreadedDLL' OR '%(RuntimeLibrary)' == 'MultiThreadedDebugDLL') AND '%(OpenMPSupport)' == 'true'".

I initially installed XE 2015 Pro update 1. Then I reverted back using windows restore points and installed 2015 release from 2gb download. I get the same result. I just bought the software and cannot use it because something deeply wrong is happening with intel's installation.I could use it for a short time but then I started getting these errors. If I change to Intel C++ with the errors I cannot change back again and VS starts crashing.

Can someone recommend a good combination of VS201X and XE compiler that works rock solid? Frankly, I bought the software because I need all the optimization I can get but I'm appalled by a seemingly poor job of testing of deployment, judging by what I read in the forum.

0 Kudos
16 Replies
Kirk_D_
Beginner
177 Views

I have had similar issues related to the VS2013 updates.  The solution I found is pretty painful - uninstall the Intel Studio, uninstall CUDA, apply the VS 2013 Update, then reinstall Intel and CUDA.  This takes a lot of time (granted it is relatively few user actions followed by staring at mind-numbing progress screens for hours), but it would be nice if did not need to fiddle around like this. 

Kirk

Bruno_A_1
Beginner
177 Views

No one has a recommended setup for 2015 ? I'm currently planning on installing VS2013 Update 3.

JenniferJ
Moderator
177 Views

do you have CUDA integrated into VS2013? could you send the link for the CUDA you installed? I'd like to try that.

It might be a coexistence issue.

Did you install the Intel Parallel Studio XE 2015 update 1?

Jennifer

Bruno_A_2
Beginner
177 Views

Jennifer J. (Intel) wrote:

do you have CUDA integrated into VS2013? could you send the link for the CUDA you installed? I'd like to try that.

It might be a coexistence issue.

Did you install the Intel Parallel Studio XE 2015 update 1?

Jennifer

Dear Jennifer, thanks for getting back to me. I was trying to submit a ticket through premier support but the system appears to be having some difficulties.

I just re-installed everything on a fresh windows 7 pro x64 re-install and I found the same error after switching several times between IC++ and VS++. I initially have an error with MKL not finding cmd(sp?) but then eventually I get the same error. I got this same error using VS2013 Update 3 + XE 2015 Update 1. 

You may be onto something with your CUDA reference. I am using a very new one that has support for 980 GTX. This is where I got it from: https://developer.nvidia.com/cuda-downloads-geforce-gtx9xx . I did install CUDA after I did the XE 2015 this time, but not originally, I had CUDA before.

Is there a recommended version of VS2013 and XE 2015 you recommend? The release notes do not mention with vs2013 update it was tested with.

warm regards,

JenniferJ
Moderator
177 Views

Do you have this issue without installing CUDA? is your project a console helloworld project?

The Intel Parallel Studio XE 2015 should work with the latest update of VS2013.

Jennifer

Bruno_A_2
Beginner
177 Views

Hi Jennifer, I will try and test it without cuda and get back to you.

So you advise installing VS2013 Update 4 and Intel 2015 XE Update 1?

Bruno_A_2
Beginner
177 Views

Hi,

I installed VS2013 U4, XE 2015 U1 and the first time I run a win32 console app, I create a new configuration for x64, based on Win32. Then I change it to IC++ using the menu.I get this:

1>------ Build started: Project: ConsoleApplication5, Configuration: Debug x64 ------
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 15.0\ImportBefore\Intel.Libs.MKL.Intel C++ Compiler XE 15.0.targets(65,5): error MSB6003: The specified task executable "cmd.exe" could not be run. The working directory "mkl\tools" does not exist.

Program is simple:

// ConsoleApplication5.cpp : Defines the entry point for the console application.
//

#include "stdafx.h"
#include <iostream>

int _tmain(int argc, _TCHAR* argv[])
{
	system("pause");
	return 0;
}

Then, if I'm in Win32 (IC++) and then go in the menu and do Convert to VC++ I get the same as before:

C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\x64\PlatformToolsets\v120\ImportBefore\Intel.Libs.IPP.v120.targets(41,32): A numeric comparison was attempted on "$(IPPMajorVersion)" that evaluates to "" instead of a number, in condition "$(IPPMajorVersion) > 7 AND ('%(RuntimeLibrary)' == 'MultiThreadedDLL' OR '%(RuntimeLibrary)' == 'MultiThreadedDebugDLL') AND '%(OpenMPSupport)' == 'true'".

 

Then it says it cannot proceed and VS crashes.

I'm using VS2013 Pro. Should I trial another version, ultra, premium? I can get another version if it makes it work.

Bruno_A_2
Beginner
177 Views

If I convert a Win32 IC++ project to x64, then disable all the Intel Performance Libraries, leaving only the Use Intel IPP, I get this:

1>------ Build started: Project: ConsoleApplication6, Configuration: Debug x64 ------
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 15.0\ImportAfter\Intel.Libs.IPP.Intel C++ Compiler XE 15.0.targets(37,5): warning : Could not expand IPPMajorVersion variable. The registry information may be incorrect.
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 15.0\ImportAfter\Intel.Libs.IPP.Intel C++ Compiler XE 15.0.targets(38,5): warning : Could not expand IPPMinorVersion variable. The registry information may be incorrect.
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 15.0\ImportAfter\Intel.Libs.IPP.Intel C++ Compiler XE 15.0.targets(39,5): warning : Could not expand IPPIncludeDir variable. The registry information may be incorrect.
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 15.0\ImportAfter\Intel.Libs.IPP.Intel C++ Compiler XE 15.0.targets(40,5): warning : Could not expand IPPLibDir variable. The registry information may be incorrect.
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 15.0\ImportAfter\Intel.Libs.IPP.Intel C++ Compiler XE 15.0.targets(41,5): warning : Could not expand CPPLibDir variable. The registry information may be incorrect.

vs2013icc.png

JenniferJ
Moderator
177 Views

It seems many things went wrong. it may take a while to find out all the issues. did you have the Intel Parallel Studio XE beta program installed earlier on the machine? Also this file "C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Intel.Misc.Utilities\v4.0_15.0.12.0__f4875dd4c8d7762f\Intel.Misc.Utilities.dll", is the file version "16.0.65.12"? Please file an issue to Intel Premier Support. Jennifer
Bruno_A_2
Beginner
177 Views

Ok, I believe I have figured out the issue. I'm not sure it is a bug, but it looks like one to me, at least, it breaks expected behavior. If you change the settings at top most level of properties to use performance libraries, then it can find all the variables of IPP, MKL, etc. If you don't, then it cannot. So, it means that by default they need to be activated and then disabled further down in the hierarchy. This does not let you disable by default and only enable when you want. (which is useful)

Looks like a bug to me. Btw, I think you meant "15.0.65.12", not 16.xx. Yes, I have that version. 

JenniferJ
Moderator
177 Views

It's great that you've got this figured out. Yes, it seems a bug to me.

>> If you change the settings at top most level of properties to use performance libraries

what do you mean the "top most level of properties"?

Thanks,

Jennifer

Le_T_
Beginner
177 Views

Hi all. I use VS2013 x64 + XE 2015 and everything was fine. After the last update for XE, I cannot run my old code anymore. I got the same error as Bruno did: 

"error MSB6003: The specified task executable "cmd.exe" could not be run. The working directory "mkl\tools" does not exist"

Can anyone tell me how to fix it?

 

emmanuel_attia
Beginner
177 Views

Same issue here.

Intel integration assume by default my C++ projects would use MKL, I have to explicitely set MKL usage to "No".

I have not installed MKL, I don't intend to use it, I wish i would not have to opt-out linking of libraries that I don't need and not even installed.

 

Best Regards

TheClassic
Beginner
177 Views

It seems like I was able to remove the mkl targets and props files from C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\Win32\PlatformToolsets\v120\ImportBefore (and ImportAfter) and the problem went away. Look at the path in the error as yours may be a bit different.

Joost_G_1
Beginner
177 Views

Hi,

I had exactly the same issue. Instead of messing about with settings I reinstalled Intel parallel studio, and now also added the Visual Studio 2015 extensions. This solved it.

A colleague just uninstalled parallel studio and that solved the problem too.

Kind regards,

Joost Geerdink/ikku100

Ps. if this doesn't work, make sure you uninstall all parallel studio installations and do it again.

MELVYN_B_
Beginner
177 Views

Dear Colleagues,

Using Visual Studio 2017 Community and Intel® Parallel Studio XE 2017 Update 4 for Windows, setting Use Intel® MKL to NO and setting Use Intel® DAAL to NO has resolved this issue allowed the Build to succeed for a mixed C++ and ASM program both under x86 and under x64 configurations where the ASM file contained alternate code for IFDEF ASMX86_32 and IFDEF ASMX86_64, respectively. with corresponding Properties -> Configuration Manager -> Microsoft Macro Assembler -> General -> Preprocessor Definitions for each configuration.

Thank you all for your kindness in contributing and sharing your expertise.

 

 

Reply