Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
7679 Discussions

Visual Studio 2013: cannot open file libmmd.lib on vc++ projects

Curtis_H_
Beginner
883 Views

I downloaded and installed the trial of Parallel Studio XE 2015 for Windows, and tried to use it to compile a Visual Studio 2013 solution.  This solution contains about 50 vc++ projects.  Some use MFC, others are test projects.  I started by right clicking the solution in the Solution Explorer, and selecting Intel Compiler -> Use Intel C++.  I didn't want to use the Intel Compiler for the test projects, so I set them back to use VC++ by right clicking on the project, selecting Intel Compiler -> Use Visual C++.  There are a few other production projects where I did this as well.

Now, the projects that use the Visual C++ compiler cannot build.  The linker comes back with the error "LNK1104: cannot open file 'libmmd.lib'.  I went to the Input section of the Linker under Project Properties in order to remove libmmd.lib from "Additional Dependencies", but it's not there. Projects the use the Intel compiler can build just fine. 

 

0 Kudos
2 Replies
Curtis_H_
Beginner
883 Views

Figured it out.  Just needed to add  C:\Program Files (x86)\Intel\Composer XE 2015\compiler\lib\ia32; to "Additional Library Directories" under Project Settings-> Linker->General, for all the projects that were giving the linker error.

JenniferJ
Moderator
883 Views

Right. it's because of the dependency.

When using the dll or lib built with ICL in a project that is not using ICL, you need to add the ICL's library dir to the linker. When you run the program, the ICL's redist-dir should be on the "path" as well. But this should have been taken care of during installation. If not, you need to add explicitly.

Jennifer

Reply