Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Miket
Beginner
102 Views

Visual Studio 2015 RTM - Intel compiler fails (2016 update 2)

Jump to solution

Hello All,

Today I installed Visual Studio 2015 Community edition (RTM) and discovered that a very simple code won't compile with Intel 2016 Compiler (update 2, Version 16.0 Beta Build 20150527).

The code:

#include <string>
#include <iostream>

using namespace std;

int main()
{
    cout << "Hello!!";
    return 0;
}

The error message:

1>C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\type_traits(1617): error : a nonstatic member reference must be relative to a specific object
1>            -> decltype(_STD invoke(get(), _STD forward<_Types>(_Args)...))

Hope it will be fixed in the next release, since it is complete show-stopper!

Regards,

       Michael

0 Kudos
1 Solution
Judith_W_Intel
Employee
102 Views

 

You could try adding /Qstd=c++11 to the command line (the problem was that the c++11 feature of allowing "this" in trailing return types was not enabled by default for MSVC++ 2015 configurations. The /Qstd=c++11 option should automatically add this option.

Judy

View solution in original post

4 Replies
Melanie_B_Intel
Employee
102 Views

Thank you, we're tracking this problem as DPD200372590 in our internal bugs database. It should be fixed in the next revision.

Miket
Beginner
102 Views

Of course, you cannot say when the next update will be available...

Any temporary workaround?

I am afraid that this issue is complete disaster not only for me. I was forced to uninstall this Beta completely.

 

Regards,

    Michael

 

Judith_W_Intel
Employee
103 Views

 

You could try adding /Qstd=c++11 to the command line (the problem was that the c++11 feature of allowing "this" in trailing return types was not enabled by default for MSVC++ 2015 configurations. The /Qstd=c++11 option should automatically add this option.

Judy

View solution in original post

Miket
Beginner
102 Views

Thank you a lot, Judy! It works.

Michael

 

Reply