Community
cancel
Showing results for 
Search instead for 
Did you mean: 
pvonkaenel
New Contributor III
76 Views

Visual Studio Integration

Hi all,

Even though I have a C++ Pro license, I have been installing just the stand alone IPP component. I have put together a set of environment variables and Visual Studio property sheets to make it easy to include the proper version of IPP in my applications.

I just installed the full package which includes IPP, and I noticed there is built-in Visual Studio integration for the other package that come with the Compiler Pro (IPP, MKL, and TBB). Great, I decided to undo my env vars and property sheets and just checked the IPP check box. To my surprise it worked perfectly, which is a little strange since I want to link with the static unthreaded version of IPP. I have the compiler set up to compile with /MT instead of /MD, and I do not have /OpenMP enabled. Is it because of this that the static/unthreaded version of IPP is being used, and will it change if I change to /MD and /OpenMP?

Thanks,
Peter
0 Kudos
8 Replies
pvonkaenel
New Contributor III
76 Views


I just noticed that even though it build fine in Visual Studio, if I try to build using something like:

devenv HNJLibs.sln /Build "Release|Win32"

it fails when trying to find the IPP headers (I assume the same problem would exist for MKL and TBB). Normally I'd post this to the IPP forum, but it looks like a problem with the C++ compiler VS integration.

In the project settings, there is reference to $(INTEL_DEF_IA32_INSTALL_DIR)IPPia32Include. Where is the INTEL_DEF_IA32_INSTALL_DIR variable defined?

Thanks,
Peter
JenniferJ
Moderator
76 Views

Quoting - pvonkaenel
In the project settings, there is reference to $(INTEL_DEF_IA32_INSTALL_DIR)IPPia32Include. Where is the INTEL_DEF_IA32_INSTALL_DIR variable defined?

This is defined as a Macro. So within IDE, you can open any of the project property field (editable), and select "Edit", then expand the macro ">>". It should be displayed there.

So you're right. It's more like a bug in the compiler's IDE integration. Let me try to duplicate and file a bug for it.

Thanks for finding out the root cause.

Jennifer
pvonkaenel
New Contributor III
76 Views

Hi Jennifer,

Do you know if this was fixed in the recently released 11.1 Update 5 release? I'd really like to get away from my property sheets in favor of the easir to use VS integration.

Thanks,

Peter

JenniferJ
Moderator
76 Views

Hi Peter,

Sorry I was lost track of this one issue. I'll submit a bug report now.

I did find a work-around for it. Try to set the projec to use Intel C++. Then it will be built fine from "devenv".

Thanks,
Jennifer
pvonkaenel
New Contributor III
76 Views

I just tried this out again in 11.1 Update 6 and it still seems to be busted.

Peter
pvonkaenel
New Contributor III
76 Views

I just tried it again, and I think it is working. Could you verify it for me? I don't know if it's really fixed, or if I have things part way installed.

Thanks,
Peter
JenniferJ
Moderator
76 Views

I tried it and it did work for me.

Please make sure you have the latest IDE integration.
"C:\Program Files (x86)\Intel\Compiler\11.1\065\VS Integration\C++\VS2008\IntelPkg.dll", it should have version "11.1.850.200x". It's from the 11.1 update 6 package.

do you see the same version?

If you have the same version, could you paste the error msg here? and the .vcproj/.icproj files (you can use "private" response if you prefer).

Thanks,
Jennifer
pvonkaenel
New Contributor III
76 Views

I think it's all good now - I think I was still using update 5 in my test after installing update 6.

Thanks,
Peter
Reply