Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Yuandong_W_Intel
Employee
301 Views

Where is the x32 ABI compiler libraries?

I am using icc19.4 on ubuntu18.

I want to use -mx32 option to generate some Linux x32 ABI object files and link the x32-compatible libraries (libimf.so and libirc.so).

But I didn't found the x32-compatible libraries in the directory icc19.4/compiler/lib.

So how to do it?

0 Kudos
8 Replies
GouthamK_Intel
Moderator
301 Views

Hi Yuandong,

We verified with icc 19.1 version in ubuntu 18.04 and we are able to find libimf.so and libric.so files in "/opt/intel/inteloneapi/compiler/2021.1-beta04/linux/compiler/lib/intel64_lin/libimf.so" and "/opt/intel/inteloneapi/compiler/2021.1-beta04/linux/compiler/lib/intel64_lin/libirc.so"  respective paths.

As you have mentioned that you are using icc19.4, whereas the latest version of icc is 19.1. Please recheck the icc version which you are using and let us know.

 

Regards

Goutham

301 Views

did you check that x32 is supported? I see -m32 and -m64 options there.

Vladimir 

Yuandong_W_Intel
Employee
301 Views

Vladimir Polin (Intel) wrote:

did you check that x32 is supported? I see -m32 and -m64 options there.

Vladimir 

I see it is supported on previous documentation. Not sure about current version.

https://software.intel.com/en-us/node/628948

 

GouthamK_Intel
Moderator
301 Views

Hi Yuandong,

We verified that -mx32 flag is not supported in the current icc version (19.1).

Can you please let us know which version of icc you are using? 

you may also try using -m32 option and let us know if your issue is resolved. 

 

Regards

Goutham

Yuandong_W_Intel
Employee
301 Views

Kuncham, Goutham Kalikrishna Reddy (Intel) wrote:

Hi Yuandong,

We verified that -mx32 flag is not supported in the current icc version (19.1).

Can you please let us know which version of icc you are using? 

you may also try using -m32 option and let us know if your issue is resolved. 

 

Regards

Goutham

 

Hi, Goutham.

I'm using icc19.4 so it is also assumed x32 not supported.

I must use x32 there, so I'm trying other way.

Anyway, thanks for your help.

Viet_H_Intel
Moderator
301 Views

The -mx32 is supported in Bi-Endian compiler, not in PSXE.

Viet_H_Intel
Moderator
142 Views

Let us know if this is still an issue. Otherwise, we will close it.


Thanks,


Viet_H_Intel
Moderator
128 Views

We will no longer respond to this thread.  

If you require additional assistance from Intel, please start a new thread. Any further interaction in this thread will be considered community only.

Thank,


Reply