Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

cannot find -lstdc++

Sangeeta_M_
Beginner
857 Views

Dear All,

This is my very attempt to instll intel compilers in centos system. I have downloaded l_ccompxe_2013_sp1.1.106.tgz for c compiler. After ./install.sh and sourcing the files as provided in the net, just to check the performance of icc, i also took a sample program available in the internet and executed the command

[root@MAX Desktop]# icc first.c
ld: cannot find -lstdc++

[root@MAX ~]# locate libstdc++.so.6
/opt/intel/composer_xe_2013_sp1.1.106/bin/sourcechecker/lib/ia32/pinruntime/libstdc++.so.6
/opt/intel/composer_xe_2013_sp1.1.106/bin/sourcechecker/lib/ia32/pinruntime/libstdc++.so.6.0.10
/opt/intel/composer_xe_2013_sp1.1.106/bin/sourcechecker/lib/intel64/pinruntime/libstdc++.so.6
/opt/intel/composer_xe_2013_sp1.1.106/bin/sourcechecker/lib/intel64/pinruntime/libstdc++.so.6.0.10
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.13
/usr/share/gdb/auto-load/usr/lib/libstdc++.so.6.0.13-gdb.py
/usr/share/gdb/auto-load/usr/lib/libstdc++.so.6.0.13-gdb.pyc
/usr/share/gdb/auto-load/usr/lib/libstdc++.so.6.0.13-gdb.pyo
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.13-gdb.py
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.13-gdb.pyc
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.13-gdb.pyo

Also, I have included, export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/intel/composer_xe_2013_sp1.1.106/compiler/lib/intel64:/opt/intel/composer_xe_2013_sp1.1.106/mkl/lib/intel64
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib:/opt/intel/lib/intel64:/opt/intel/ism/lib/intel64:/lib64:/usr/lib64/libstdc++.so.6
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/intel/composer_xe_2013_sp1.1.106/bin/sourcechecker/lib/intel64/pinruntime

in .bash_profile

I would appreciate any help on it.

Thanks.

Sangeeta.

0 Kudos
6 Replies
MalReddy_Y_Intel
Employee
857 Views

Hi Sangeeta,

Please send us the output of the below two commands, ie attach the two o/p files.

$icc -# first.c >& first-icc.txt

$icc -E first.c > first.E.icc.txt

Seems some compatibility issue with the libraries.

Regards,

Reddy

 

TimP
Black Belt
857 Views

icpc should pick up the same libstdc++ as the active g++.

In your .bash_profile, you should include any PATH setting you may need to set up g++.

then 

source /opt/intel/composer_xe_2013_sp1.1.106/bin/compilervars.sh intel64

That script will take care of setting up icpc and MKL PATHs.

You could use the more generic 2013_sp1 compilervars invocation so that you don't need to edit your .bash_profile when you upgrade icpc.

When you depart from the beaten path, you must try many commands to see if everything is right:

g++ -v -print-search-dirs

icpc -V

....

Sukruth_H_Intel
Employee
857 Views

Hi,

     As Tim pointed out, You may need to check if the gcc compiler is been installed in your system where you are trying to use icc compiler. We would use some of the gcc libraries and try to be compatible with gcc.

Please check the version of the gcc being used [ gcc --version ], If gcc is not installed, then i would recomend you to do this [ for centos & Fedora ]:-

$ yum groupinstall "Development Tools"
This command would install the necessary build tools.

Please do let me know if you need any further help on this.

Regards,

Sukruth H V

 

 

Sangeeta_M_
Beginner
857 Views

Hello ,

First of all thanks for all of you. $icc -# first.c >& first-icc.txt output a fle with a message  "bash: -#: command not found". The command $icc -E first.c > first.E.icc.txt was not recoginized and gave message "bash: -E: command not found".

Also gcc version is gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-4). I have not installed g++ yet.

Will provide other informations at te earliest

Thanks & regards.

Sangeeta.
 

 

 

 

 

Sangeeta_M_
Beginner
857 Views

Hi,

$ yum groupinstall "Development Tools" made my icc to function properly. Happy!

Is it possible to keep ........../bin/compilervar.sh intel64 in  my .bash_profile ?

Thanks & regards.

Sangeeta.

ma_h_
Beginner
857 Views

hello ,Sangeeta

Is your problem solved? Can you share the solution? I encountered similar things.

 

Reply