Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
33 Views

error: 010101_45097

Hi, I get the following compiler error if I build in release mode (Visual Studio 2010 with Intel compiler 16.0), debug mode works: myexception.h(471) (col. 15): : error : 010101_45097 The error occur also if I comment out the line complained (471). Is there any description of that error? haven't found something in the net. The error looks a bit strange to me. I already tried to turn off all optimizations, but that didn't helped. Also I tried to use an older platform toolset (intel compiler 14.0), but then I don't get it start to compile and abort with message: C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 14.0\Microsoft.Cpp.x64.Intel C++ Compiler XE 14.0.targets(306,5): error : Element has an invalid value of "false". Never tried this before, maybe I just make something wrong.
0 Kudos
11 Replies
Highlighted
33 Views

Hi Marc,

I looked up in our database, and didn't find anything similar to the error message you observed.  Could you please provide a small test case, so that I can reproduce the error on my machine?

Thanks.

0 Kudos
Highlighted
Beginner
33 Views

I've seen that it happen when linkking. I'm not able to give the whole code. I'll try to create a small example, but I don't think I'll get one because the source of the problem is unknown. Do you have any suggestions how to use an older intel compiler with visual studio? Change of the toolset ends in an error (check first post)
0 Kudos
Highlighted
33 Views

It seems that some option broke the 14.0 compiler.  Please open "C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 14.0\Microsoft.Cpp.x64.Intel C++ Compiler XE 14.0.targets", and see what is in line 306.  It's likely that that line caused the problem.

0 Kudos
Highlighted
Beginner
33 Views

I tried a some different options, but I don't get an old compiler running. There is the following line 306 (removed starting less than sign because the post gets cut otherwise): ICL Condition="'%(ClCompile.PrecompiledHeader)' != 'Create' AND '%(ClCompile.ExcludedFromBuild)'!='true' AND '%(ClCompile.UseMSVC)'!='true'" the only way it starts compiling is using the code coverage dialog the run button... I have the same problem with composer xe 12.1 and 14.0, maybe the 2016 installation broke them. Is there a way to fix this?
0 Kudos
Highlighted
33 Views

Hi Marc,

I'm sending you a private message.  Please send me your "Microsoft.Cpp.x64.Intel C++ Compiler XE 14.0.targets" file to my email box.

Thanks.

0 Kudos
Highlighted
33 Views

Just in case any one else who ran into this issue (14.0.targets(306,5): error : Element has an invalid value of "false") too.  Marc confirmed that replacing his 14.0.targets file with mine solves the problem.  I'm attaching mine here.  Not clear what caused the problem yet.

Instructions: Quit VS IDE.  Backup your targets file C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\x64\PlatformToolsets\Intel C++ Compiler XE 14.0\Microsoft.Cpp.x64.Intel C++ Compiler XE 14.0.targets.  Then replace it with my targets file.  And then restart VS.

 

0 Kudos
Highlighted
Beginner
33 Views

I got this error as well using vs2013 with Intel 16.0 and linking with a fresh boost 1_61 build.  

The solution for me was to turn-off multi-file optimization.  Interprocedural Optimization No in the IDE.

Hope this helps someone.

Andrew.

0 Kudos
Highlighted
33 Views

Andrew R. wrote:

I got this error as well using vs2013 with Intel 16.0 and linking with a fresh boost 1_61 build.  

The solution for me was to turn-off multi-file optimization.  Interprocedural Optimization No in the IDE.

Hope this helps someone.

Andrew.

Hi Andrew,

Is the error you observed exactly same as what Marc saw (error : 010101_45097)?  If the error is reproducible with 16.0 update 3 compiler, please upload a small test case for me.  I'd love to look into it.

0 Kudos
Highlighted
Beginner
33 Views

Thanks Andrew,

I recently installed Intel Parallel Studio 16.0 (with update 3). I am using this with Microsoft Visual Studio 2015 (update 2). I have a project that I have been working on that builds with no errors in release mode. However, when I switched to debug mode I got the following error...

 

C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\vcruntime_exception.h(82) (col. 13): : error : 010101_45097
  
xilink: : error #10014: problem during multi-file optimization compilation (code 4)
xilink: : error #10014: problem during multi-file optimization compilation (code 4)

 

I checked the property pages for my project in Visual Studio and the Interprocedural Optimization option was set to No in the C/C++ --> Optimization [Intel] section. However, the Interprocedural Optimization option under the Linker settings was set to Yes. After switching this to No, my project built with no errors.

 

0 Kudos
Highlighted
Beginner
33 Views

I have encountered the same error code, Intel C++ Compiler 17.0 (2017.4.210), building in release mode, with various optimisations enabled.

The line on which the error was reported was a trivial access function, returning a char* - an unlikely culprit for anything pernicious.

Doug's suggestion of disabling interprocedural optimisations allowed the build to complete. Thanks Doug.

 

(I do have less confidence in it than I might, however, with an undocumented error being emitted for unknown reasons.)

0 Kudos
Highlighted
Moderator
33 Views

it seems like a bug again. this type of bugs is not easy to reproduce. in case you have a reproducer, could you report & share it to Intel Online service center?

thank you very much,

Jennifer

0 Kudos