Community
cancel
Showing results for 
Search instead for 
Did you mean: 
shyaki
Beginner
179 Views

error #2277: invalid definition of __m128; use #include "xmmintrin.h" instead

I got this error when using the Intel 64-bit compiler in the custom build tool of VS2010.
0 Kudos
2 Replies
TimP
Black Belt
179 Views

You need include only a single level of <*intrin.h>; for SSE2 support, for example. Your compiler options must support the equivalent or higher SSE level, e.g. /arch:SSE2 (default for X64 and even for current 32-bit versions). ICL doesn't pick one for you, and doing so would violate the C or C++ standard; you must include it explicitly. You would likely prefer one which is present in all the compilers you intend to use.
jayzzz
Beginner
179 Views

When you try to compile with Intel Compiler, it's recommended to use head files from Intel rather than from Microsoft. Add parameter below before all other include paths may solve this problem.
(note: the path may be different according to your installation)
[bash]/IC:Progra~1IntelComposerXE-2011compilerinclude[/bash]
Reply