Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Petros_M_
Beginner
313 Views

error TRK0005: Failed to locate: "icl.exe". The system cannot find the file specified.

I had just my machine rebuilt, because I could not update the intel software tools.

I installed the parallel studio XE 2017 (basic)

I am using win7, 64bit with VS2010, VS2013 and VS2015.

I received the error:

"error TRK0005: Failed to locate: "icl.exe". The system cannot find the file specified."

in VS2015 (debug, 64bit)

After reading on the web about possible path shortening (a well-known windows artifact, that there was no way to be anticipated or worked-around- I presume!), I decided to fire-up devenv.exe from the command prompt of PSXE 2017, which worked fine!

Now, I would like to be able to not have to go through this every time I start Visual Studio.

There is a bunch of locations in which icl.exe resides:

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows\bin\intel64_ia32

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows\bin\intel64

and :

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows\bin\ia32

which one should I use? It seems -I wish- the first is a wrapper for the other two. Is this correct?

TIA,

Petros

 

 

 

0 Kudos
7 Replies
JenniferJ
Moderator
313 Views

Within VS IDE, you should not need to see which "icl.exe" to use. it's all taken care of automatically by the project configuration.

To build a project with Intel C, should do the following:

1) right click on the project(s), select "Intel Compiler" > "Use Intel C++".

is this what you did? If this is not an usage issue, it'd be better to report it to Intel Online Service Center. Here is the steps to do that: https://software.intel.com/en-us/articles/how-to-create-a-support-request-at-online-service-center

Jennifer

SKost
Valued Contributor II
313 Views

>>There is a bunch of locations in which icl.exe resides: >> >>C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows\bin\intel64_ia32 This is for 32-bit applications. >> >>C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows\bin\intel64 This is for 64-bit applications. >>... >>...which one should I use? It depends on a type of application you're going to build, 32-bit or 64-bit. >>...It seems -I wish- the first is a wrapper for the other two. Is this correct? No, this is not correct. If you are developing a 32-bit application the 1st one needs to be used. If you are developing a 64-bit application the 2nd one needs to be used.
SKost
Valued Contributor II
313 Views

>>...Within VS IDE, you should not need to see which "icl.exe" to use... An information about a version and build date of Intel C++ compiler is always displayed in the Output Window of a VS.
Petros_M_
Beginner
313 Views

Sergey,

Thank you for your replies.

Per the first one, although the first two cases are obvious to me, the latter is not (i.e. I do not know what purpose it serves-no worries, I can continue living without knowing)

Per your second email, I have to say that when I compiled the way I described, the logo banner did not come up!.

Now, per the real heart of the question, do you have a suggestion for making it work just by setting the compiler from within the IDE, without having to start the IDE from the appropriate intel-provided command prompt

PS: there might be other reasons that make this less a matter of taste and more of a necessity. Currently, I am in another bind with CMake which tries to validate attributes of the used compiler by running MSBuild,exe, without necessarily starting things from such an environment.

(But please, let's focus on the specific problem, CMake is addressed elsewhere)

Petros_M_
Beginner
313 Views

Maybe unrelated -although I don't think so- when running CMake as described above, the diagnostics set by CMake fail to compile in a very basic manner. For example, the first offense reads: 

Build started 6/8/2017 12:09:14 PM.

Project "C:\_petros\_dev\math_dev\_build_trees\x64\vc14-intel-17_0_0\CMakeFiles\3.9.0-rc2\CompilerIdCXX\CompilerIdCXX.vcxproj" on node 1 (default targets).

PrepareForBuild:

Creating directory "Debug\".

Creating directory "Debug\CompilerIdCXX.tlog\".

InitializeBuildStatus:

Creating "Debug\CompilerIdCXX.tlog\unsuccessfulbuild" because "AlwaysCreate" was specified.

MessageBuildingWithCompiler:

Building with Intel(R) C++ Compiler 17.0

ClCompile:

***** ClCompile (x64 - Intel C++)

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows\bin\intel64\icl.exe /c /Qm64 /nologo /W0 /Od /D __INTEL_COMPILER=1700 /D _MBCS /EHsc /RTC1 /MDd /GS /Zc:wchar_t /Zc:forScope /Fo"Debug\\" /Fd"Debug\vc140.pdb" /TP CMakeCXXCompilerId.cpp

CMakeCXXCompilerId.cpp

Link:

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows\bin\intel64\xilink.exe -qm64 /OUT:".\CompilerIdCXX.exe" /INCREMENTAL:NO /NOLOGO kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib /MANIFEST /manifest:embed /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /PDB:".\CompilerIdCXX.pdb" /SUBSYSTEM:CONSOLE /TLBID:1 /DYNAMICBASE /NXCOMPAT /IMPLIB:".\CompilerIdCXX.lib" /MACHINE:X64 Debug\CMakeCXXCompilerId.obj

LINK : : error LNK1104: cannot open file 'libmmdd.lib'

Done Building Project "C:\_petros\_dev\math_dev\_build_trees\x64\vc14-intel-17_0_0\CMakeFiles\3.9.0-rc2\CompilerIdCXX\CompilerIdCXX.vcxproj" (default targets) -- FAILED.

Build FAILED.

 

Petros_M_
Beginner
313 Views

At this point, after I cleared what is happening with CMake, it is obvious that the Intel PSXE 2017 installation -despite its final statement-is incomplete.

The way CMake identifies the compiler attributes is by creating visual studio projects under the hood, endow them with the appropriate tool-chain and try to build them using MSBuild.

Therefore the incompleteness of the installation, prompting for my initial inquiry, re-surfaces again!

Can someone please give me a concrete answer for what has one to do to properly install PSXE 2017?

TIA,

Petros

Update: I am looking in the VS macros as defined by the installation:

As one easily notices ICLIncludeDir is(basically) C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017\windows\compiler\include

However, in:

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017

the only thing to be found is a redist folder with 2 empty folders underneath (ia32_win and intel64_win)

If instead it was pointing to:

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.0.109\windows\compiler\include

then there would be similarly some header files to include ! 

ICLibDir goes through the same faulty pointing.

So, it is obvious that the installation has serious problems (this is after a "repair"!)

Seriously?

Update 2: Looking at the registry, it seems that everything is driven of ICInstallDir. How Can I overwrite this?

 

 

Petros_M_
Beginner
313 Views

Hi

It has been since Friday!

Can someone please respond?

TIA, Petros