Intel® C++ Compiler
Support and discussions for creating C++ code that runs on platforms based on Intel® processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
7568 Discussions

fatal error LNK1146: no argument specified with option '/LIBPATH:'

AdamD85
Beginner
420 Views
I am using MS Visual Studio 2008. (Windows 7, 64bit)

I have installed Intel Compiler C++ version 11.1.065 in order to use MKL Library.

After installation I have:
1) Changed in Solution Explorer from VS -> Intel C++ Complier

but when I try to build my project there is an error:

1>LINK : fatal error LNK1146: no argument specified with option '/LIBPATH:'

a) Do I need to change something else in Project properties ?
b) Do I need to add something in environment settings ?


Please help me,

A.
0 Kudos
2 Replies
Milind_Kulkarni__Int
New Contributor II
420 Views
Can you send me output of from the Tools> VS2008 Command Prompt. To check the environment options and if the variable if set..

Do you face the problem with simple app with 1 .cpp file etc, or is related when MKL is being used.
Does this come with VS project also?

1. By accident or coincidence, /LIBPATH is getting used in your linker options.. Check under Properties> Linker> Command Line> if you have /LIBPATH: present by mistake.

2. Though you may have environment variable LIBPATH set, specifying /LIBPATH: in Linker will, override the env settings.

3. You can try this workaround:-- specify directories that need to be searched for any libs, or something like :-- "C:" or "$(Outdir)" to make the option non-empty, and check f it helps.

4. Let me know if its MKL-related and then would need to divert to appropriate forum.
regards
Om_S_Intel
Employee
420 Views

To set this linker option in the Visual Studio development environment

1. Open the project's Property Pages dialog box. For details, see Setting Visual C++ Project Properties.

2. Click the Linker folder.

3. Click the General property page.

4. Modify the Additional Library Directories property.

Reply