Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
100 Views

getting boost.org c++ libraries using the intel compiler

Hello,
I have downloaded the trial version of intel C++ compiler (11.1.065)
I have extraced the boost files to the folder "C:\\boost_1_37_0\\boost_1_37_0"
I have invoked bjam using the foll command
bjam --Build-dir=C:\\boost_1_37_0\\boost_1_37_0\\intel" --toolset=intel --build-type=complete stage
I see the foll error

WARNING: No python installation configured and autoconfiguration

failed. See http://www.boost.org/libs/python/doc/building.html

for configuration instructions or pass --without-python to

suppress this message and silently skip all Boost.Python targets

warning: No toolsets are configured.

warning: Configuring default toolset "msvc".

warning: If the default is wrong, your build may not work correctly.

warning: Use the "toolset=xxxxx" option to override our guess.

warning: For more configuration options, please consult

warning: http://boost.org/boost-build2/doc/html/bbv2/advanced/configuration.html

warning: Graph library does not contain optional GraphML reader.

note: to enable GraphML support, set EXPAT_INCLUDE and EXPAT_LIBPATH to the

note: directories containing the Expat headers and libraries, respectively.

warning: skipping optional Message Passing Interface (MPI) library.

note: to enable MPI support, add "using mpi ;" to user-config.jam.

note: to suppress this message, pass "--without-mpi" to bjam.

note: otherwise, you can safely ignore this message.

Skipping build of: libs/python/build/boost_python no in common properties

Building Boost.Regex with the optional Unicode/ICU support disabled.

Note: Please refer to the Boost.Regex documentation for more information

Note: this is a strictly optional feature.

Skipping build of: libs/python/build/boost_python no in common properties

...patience...

...patience...

...found 4071 targets...


I am able to build in VisualStudio.
How do I generate the boos libraries for the Intel Compiler ?

0 Kudos
2 Replies
Highlighted
Employee
100 Views

I'll take care about your request, but give me some time to investigate.
Thanks&regards,
Hubert Haberstock
0 Kudos
Highlighted
Employee
100 Views

I ran a boost build test (however with newest boost _1_43_0), but didn't find such failures. The crucial part on your side, I believe, is that --toolset=intel fails.

There is a knowledge base article at http://software.intel.com/en-us/articles/building-boost-with-intel-c/ which may help. This articel describes boost with using Intel Parallel Studio, but the procedure is the same for the classic Intel C++ Compiler 11.1.

I ran into another issue that was very related to this forum thread at http://software.intel.com/en-us/forums/showthread.php?t=71983.

You may also search for other occurrences of boost forum threads to get some help.

Regards,

Hubert.

0 Kudos