Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
35 Views

icc: error #10310

Jump to solution
Recently I downloaded free evaluation intel compiler and installed it on Ubuntu 9, installation was sucessful, however, when I ran the compiler, I got the following error,

ubuntu01:~$ /opt/intel/Compiler/11.1/046/bin/ia32/icc
icc: error #10310: Failed to enable trusted storage check for licensing: WARNING: Enable Trusted Storage failed (flexnet error code 2). Trusted Storage based license could

How to solve this problem? Thank!
0 Kudos

Accepted Solutions
Highlighted
Black Belt
35 Views


Could you please try:
source /opt/intel/Compiler/11.1/046/bin/ia32/iccvars_ia32.sh
and then type icc to see if the problem is resolved.
Thanks.
-Yang

In fact, in case the licensing depends on an environment variable setting which ought to be in the script, this looks like the right idea. However, the normal way, source /opt/intel/Compiler.11.1/046/bin/iccvars.sh ia32, should be preferred.

View solution in original post

0 Kudos
4 Replies
Highlighted
Employee
35 Views
Quoting - wwzhdo
Recently I downloaded free evaluation intel compiler and installed it on Ubuntu 9, installation was sucessful, however, when I ran the compiler, I got the following error,

ubuntu01:~$ /opt/intel/Compiler/11.1/046/bin/ia32/icc
icc: error #10310: Failed to enable trusted storage check for licensing: WARNING: Enable Trusted Storage failed (flexnet error code 2). Trusted Storage based license could

How to solve this problem? Thank!


Could you please try:
source /opt/intel/Compiler/11.1/046/bin/ia32/iccvars_ia32.sh
and then type icc to see if the problem is resolved.
Thanks.
-Yang

0 Kudos
Highlighted
Black Belt
36 Views


Could you please try:
source /opt/intel/Compiler/11.1/046/bin/ia32/iccvars_ia32.sh
and then type icc to see if the problem is resolved.
Thanks.
-Yang

In fact, in case the licensing depends on an environment variable setting which ought to be in the script, this looks like the right idea. However, the normal way, source /opt/intel/Compiler.11.1/046/bin/iccvars.sh ia32, should be preferred.

View solution in original post

0 Kudos
Highlighted
Beginner
35 Views
Quoting - tim18
In fact, in case the licensing depends on an environment variable setting which ought to be in the script, this looks like the right idea. However, the normal way, source /opt/intel/Compiler.11.1/046/bin/iccvars.sh ia32, should be preferred.

Thanks! it solved the problem. I should run this script right after I findish installation.
Another question, looke like icc needs libstdc++.so.5
error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory.

I have libstdc++.so.6 installed on this ubuntu 9 machine? Shall I install libstdc++.so.6 or is there any other way to solve it?

0 Kudos
Highlighted
Black Belt
35 Views
The best way is to add libstdc++.so.5, if it's available as an option for the distro. If not, there's a chance a symlink may work. Ron Green has a guide for Ubuntu installation at the top of the Fortran linux forum:
http://software.intel.com/en-us/articles/using-intel-compilers-for-linux-with-ubuntu/
0 Kudos