Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Darren_Smith
Beginner
134 Views

idb doesn't start

Hello,

I've just installed Parallel Studio XE, in order to evaluate it. The icpc compiler seems fine, and also the command line debugger, idbc.

However the GUI debugger - idb - is not working.

Our system is a 64 bit Intel box, running SUSE Linux Enterprise Server 10 (x86_64).

java -version gives: Java 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
XE composer is version composerxe-2011.0.084

When I issue the idb command (just "idb" without any parameters), nothing happens. No gui appears, there are no error messages written to console. After about 1 sec the console prompt returns and echo $? gives 13.

I notice there are log files under ~/.idb_12.0_linux_intel64_app/configuration. I see logs of "Bunde.... ....was not resolved." for varies bundle names. There are also some errors inthe log:

grep -i error
!MESSAGE An error occurred while automatically activating bundle org.eclipse.ui.workbench (290).
Caused by: java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
!MESSAGE An error occurred while automatically activating bundle com.intel.debugger.ui.rcp (9).
Caused by: java.lang.NoClassDefFoundError: org/eclipse/ui/plugin/AbstractUIPlugin
java.lang.NoClassDefFoundError: org/eclipse/ui/plugin/AbstractUIPlugin
!MESSAGE Application error
Caused by: org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle com.intel.debugger.ui.rcp (9).
Caused by: java.lang.NoClassDefFoundError: org/eclipse/ui/plugin/AbstractUIPlugin

Any suggestions on how to get idb working?

0 Kudos
9 Replies
Hubert_H_Intel
Employee
134 Views

I'll have a closer look at this and will give you an answer once I have a result.
Hubert.
Hubert_H_Intel
Employee
134 Views

I couldn't find a real answer for the problem, but I guess it might have something to do with the JRE you are using. Could you please download the actual JRE from www.java.com (check for the right platform 32/64bit) and install the package on a temp folder (e.g. your $HOME)and expand your PATH on command line manually (just for test purposes), for example:
$ export PATH=~/jre1.6.0_20/bin:$PATH
$ java -version
java version "1.6.0_20"
Java SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot Server VM (build 16.3-b01, mixed mode)
$

Pls. have a try.
Hubert.

Darren_Smith
Beginner
134 Views

Hello,

Thanks for your reply - I've now got a bit further.

I downloaded jre-6u24-linux-x64.bin and installed under my home:

~ java -version
java version "1.6.0_24"
Java SE Runtime Environment (build 1.6.0_24-b07)
Java HotSpot 64-Bit Server VM (build 19.1-b02, mixed mode)

Issuing the idb command (from the SUSE box) now causes a grey feature-less
square to briefly appear on my Windows box (which is running Exceed X-Server). Then
idb dies:

~ idb

(.:23317): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/etc/opt/gnome/gtk-2.0/gdk-pixbuf64.loaders': No such file or directory

(.:23317): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `pixbuf != NULL' failed

(.:23317): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `pixbuf != NULL' failed

(.:23317): Gtk-CRITICAL **: gtk_window_resize: assertion `width > 0' failed
Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'Failed to load Pango module for id: 'BasicScriptEngineFc'/app/compilers/intel_xe2011_64bit/composerxe-2011.0.084/bin/intel64/idb: line 42: 23317 Aborted (core dumped) java -jar $INSTALLDIR/debugger/gui/intel64/plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar -showsplash -gui $IDB_ARGUMENTS
~ echo $?
134

I suspect my problem is that gtk-2.0 is not installed on the SUSE box. Might be
a hassle for me to get that installed. Is there a way, maybe, to disable the need
for pango?
aazue
New Contributor I
134 Views

Hi

about: (I suspect my problem is that gtk-2.0 is not installed on the SUSE box.)
I have tested idb Debian squeeze 6 (64)
gtk2 & jre package installed
idb give same problem that you have.
without consulting trace when is loaded it result blank without messages answers.
I have removed this installation Squeeze.
for verified now the number version jre are in this distribution
but i must reinstall debian 6 with icc when i have time for extend more this problem.

http://packages.debian.org/fr/squeeze/sun-java6-jre
give:
sun-java6-jre (6.24-1~squeeze1)
probably is that i have use..
Regards

aazue
New Contributor I
134 Views

Hi
idb work perfectly now..

i have receive message in process install that jre not found
i have install this 3 packages before to continue

default-jre - Standard Java or Java compatible Runtime
default-jre-headless - Standard Java or Java compatible Runtime (headless)
sun-java6-jre - Sun Java Runtime Environment (JRE) 6 (architecture independent

I have recheck
and all process install have result success.

I think problem is it must installed the jre before process install...

I have also is installed O/.S
libgtk2.0-0
libgtk2.0-bin
libgtk2.0-common

Regards
Hubert_H_Intel
Employee
134 Views

The following may also help (if your Eclipse is older than 3.5):

$ export GDK_NATIVE_WINDOWS=1

If that doesn't help you may consider installing GTK+ from http://www.gtk.org/download-linux.html

Hubert.

aazue
New Contributor I
134 Views

Hi
idb loaded in shell have no relation eclipse
i have not shadow of this package instaled and he working perfectly
Also i have not desktop gnome installed only blackbox an twm

Regards
Darren_Smith
Beginner
134 Views

I've managed to get idb (gui) working now.

I discovered that both gtk+2 and pango were installed, but under /etc/opt/gnome and /opt/gnome - locations which idb could not find from my environment.

To fix this, I had to generate a gdk-pixbuf64.loaders config file (by calling /opt/gnome/bin/gdk-pixbuf-query-loaders-64) and then set the location of that config file in the variable: GDK_PIXBUF_MODULE_FILE

To fix the missing pango, I had to locate the pango64.modules file, and then create my own ~/.pangorc and add the contents:

[Pango]
ModuleFiles = /etc/opt/gnome/pango/pango64.modules

[PangoX]
AliasFiles = /opt/gtk2/etc/pango/pangox.aliases

So now the idb (gui) starts up fine and without warnings.
aazue
New Contributor I
134 Views

Hi
start idb as root you understand more that it start without any change
start idb as no root you understand that process is interpreted different
also make ls -a to your root directory .
you must see hidden file .idb_12.0.....etc
require you modify some file for it can can run users no root.
I have start idb no root and also distant access with Putty without any problem
same as i observe that in your answers you ignore
my comment previous threads same have no value.
I think not necessary I add more time to help you with comment precise
this change.
Regards
Reply