Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
45 Views

_intel_new_feature_proc_init

Jump to solution

c:\>icl demo.cpp

...    

LNK2019: error cannot resolve the external symbol ___intel_new_feature_proc_init,

Why?

Only "icl /Od demo.cpp" is OK,that is option /O1 and /O2 and /O3 are compiled incorrectly; What happend to it?Why all options of cl compiler are correct?

My computer's intel processor:

The third generation of Intel core i5-3210M processor core @ 2.50GHz

Step E1

Speed 2.50 GHz (100 x MHz 25)

Number of processors core number: 2 / thread number: 4

Core code Bridge Ivy

Production process 22 nm

H2 Socket (LGA 1155).

First level data cache 2 KB 32 8-Way, byte, 64 lines X

Level 1 code cache 2 KB 32 x, 8-Way, 64 lines byte

Two level cache 2 x 256 KB, 8-Way, 64 lines byte

Three level cache 3 12-Way, MB, 64 lines byte

SSE, SSE2,, SSE3, SSSE3, SSE4.1, SSE4.2, HTT,, EM64T, EIST, Boost, MMX, Turbo

0 Kudos

Accepted Solutions
Highlighted
Moderator
45 Views

Looks like the build window isn't setup correctly.

Please open the build window from "start" menu: all programs > Intel Parallel Studio xxx > Compiler and Performance Libraries...> IA32 Visual Studio xxx Mode

Then build the app from this window.

Jennifer

View solution in original post

0 Kudos
4 Replies
Highlighted
Black Belt
45 Views
You may not have the library paths set up to match your icl. Best keep Visual studio and intel compiler paths out of your basic windows settings and use the cmd start menu shortcut set up during installation. If you wish to change the installation path of icl, remove it and install with the new path.
0 Kudos
Highlighted
Beginner
45 Views

I use vs2010 to compile it,but the error list say "Cannot open impi.lib".I searched all paths of computer,I didn't find it.The "impi.lib" really exists?

0 Kudos
Highlighted
Moderator
46 Views

Looks like the build window isn't setup correctly.

Please open the build window from "start" menu: all programs > Intel Parallel Studio xxx > Compiler and Performance Libraries...> IA32 Visual Studio xxx Mode

Then build the app from this window.

Jennifer

View solution in original post

0 Kudos
Highlighted
Beginner
45 Views

Thank you for solving that problem,but why can only "IA32 Visual Studio xxx Mode"  be used to make it ?I set up "path" variable in environment  of Windows OS ,but I didn't compile it directly using "icl  somefile.cpp" by CMD window.All  in all ,thank you.

0 Kudos