Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PDL18
Beginner
361 Views

intel parallel studio xe 2019 backward compatibility

is Intel parallel studio xe 2019 backward compatible with Intel parallel studio xe 2015.

any functionalities  which are depreciated ?

0 Kudos
4 Replies
AbhishekD_Intel
Moderator
316 Views

Hi Pratik,


Parallel Studio XE has backward compatibility unless the functionality is depreciated or some major change has been made.

As you are comparing with Parallel Studio XE 2015 and 2019 there may be some major deprecation or functionality in the components of PSXE.


So please go through the below link and compare the functionalities depending on your usecase.

https://software.intel.com/content/www/us/en/develop/articles/intel-parallel-studio-xe-release-notes...



Warm Regards,

Abhishek


PDL18
Beginner
289 Views

thank you Abhishek and Viet

Viet_H_Intel
Moderator
305 Views

Binaries should be compatible. However, some command line options will be deprecated. If you have a PSXE2019 installed, you can run "icc -help deprecated" to see those options listed.


AbhishekD_Intel
Moderator
274 Views

Hi Pratik,


Thank you for your confirmation. Intel will no longer monitor this thread. Please post a new thread if you have further issues.



Warm Regards,

Abhishek


Reply