Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
71 Views

internal error: assertion failed at: "shared/cfe/edgcpfe/lower_init.c", line 11220

Hi guys, Getting *multiple* compiler errors with C++17 for ICC 19.0.5. It prevents us from using ICC in the firm forcing to migrate from ICC to clang/gcc. Does 19.0.8 solve the error? Any advice? Sorry, can not figure out the error cause and don't have time to dig in it.

internal error: assertion failed at: "shared/cfe/edgcpfe/lower_init.c", line 11220

Host: Red Hat Enterprise Linux Server release 6.10 (Santiago), GCC 8.3

Same code is compiled fine with ICC 17.0.6 and C++14 mode. Gcc/clang also compile fine.

Thanks.

0 Kudos
3 Replies
Highlighted
Moderator
71 Views

Hi,

Could you try with the latest ICC 19.1 and see if it works? 

If the latest version also throws error, kindly share the minimal reproducible code sample that is causing the error.

 

--Rahul

 

0 Kudos
Highlighted
Moderator
71 Views

Hi,

Just quick reminder to provide code sample.

 

--Rahul

0 Kudos
Highlighted
Moderator
71 Views

Hi,

We are closing this thread. Feel free to post a new thread if your issue persists.

0 Kudos