Community
cancel
Showing results for 
Search instead for 
Did you mean: 
diedro
Beginner
104 Views

linux-openmpi-compilation

dear all,

I am new in openMPI world and in general in parallelization.

I have some problems with configuration of openMPI in my laptop.

I have read your FAQ and I tried to google the problem but I was not able to solve it.The problem is:
I have downloaded the openmpi-1.6.3, unpacked it Then I have installed on my pc intel icc and icpc.when I run:./configure CC=icc CXX=icpc F77=ifort FC=ifort
I get:

 [php]
*** Startup tests

checking build system type... x86_64-unknown-linux-gnu

checking host system type... x86_64-unknown-linux-gnu

checking target system type... x86_64-unknown-linux-gnu

checking for gcc... icc

checking whether the C compiler works... no

configure: error: in `/home/diedro/Downloads/openmpi-1.6.3':configure:

error: C compiler cannot create executables

See `config.log' for more details

diedro@diedro-Latitude-E6420:~/Desktop/Downloads/openmpi-1.6.3$ 

[/php]


I do not understand why. I did a simple hello project with icc and it works.(in attachment you can fiend the config.log)

I think that it is some problem with bash file:

[php]

PATH="/opt/intel/bin/compilervars.sh intel64$PATH"
source /opt/intel/bin/compilervars.sh intel64
source /opt/intel/mkl/bin/mklvars.sh intel64 mod lp64
export PATH

[/php]

but I don not know what because as I told you when I run a simple hello project with icc and it works

Really thanks for any help

0 Kudos
6 Replies
diedro
Beginner
104 Views

dear all, My fault in the new version you need to do exactly like the FAQ told you and to not use icc or ifort o gcc, simple: [php] shell$ gunzip -c openmpi-1.6.3.tar.gz | tar xf - shell$ cd openmpi-1.6.3 shell$ ./configure --p [/php]
bernaske
New Contributor I
104 Views

Hi dedro i have download openMPI 1.6.3 and configure with the same options as you, than i compile it with make under openSUSE 12.2 M2 x86_64 with Kernel 3.6.7 and Intel Parallel Studio XE 2013 64 Bit update 1 for linux without any Problems. i think your main problems are the wrong environment settings in your bash file(s), here a sample of my .bashrc export PATH=$PATH:/opt/cuda-5.0:/usr/local/cuda-5.0/bin:/opt/intel/composer_xe_2013.1.117/bin/intel64:/opt/intel/composer_xe_2013.1.117/ipp/bin/intel64:/opt/composer_xe_2013.1.117/mkl/bin/intel64:/opt/intel/impi/4.1.0.024/intel64/bin export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/cuda-5.0/common/lib/linux/x86_64:/usr/local/cuda-5.0/lib:/usr/local/cuda-5.0/lib64:/opt/intel/composer_xe_2013.1.117/compiler/lib/intel64:/opt/intel/mkl/lib/intel64:/opt/intel/ipp/lib/intel64:/opt/intel/tbb/lib/intel64:/opt/intel/impi/4.1.0.024/intel64/lib export IPPROOT=/opt/intel/composer_xe_2013.1.117/ipp i use this settings for all users and any user can compile the openMPI-1.6.3 without any problems cheers Franz
diedro
Beginner
104 Views

Dear Franz, I do not understand. do you simple run "./configure --p"? this means that you use the default gcc,g++ and gnufort to compile openMPI, is it right? in your bash I do not understand especially "export IPPROOT=/opt/intel/composer_xe_2013.1.117/ipp" I use [php] PATH="/opt/intel/bin/compilervars.sh intel64$PATH" source /opt/intel/bin/compilervars.sh intel64 source /opt/intel/mkl/bin/mklvars.sh intel64 mod lp64 export PATH [/php] In this way when I compile a simple hello project it works with icc or ifort. ./configure ././configure CC=icc F77=ifort FC=ifort configure CC=icc F77=ifort FC=ifort does not work. what do you think? thanks
TimP
Black Belt
104 Views

Please follow openmpi faq about configure and how to ask questions. Does reported error relate to failure to specify CXX=icpc?
diedro
Beginner
104 Views

dear TimP and Franz, I have followed the FAQ. In the FAQ the say that the most common problem is that most people use icc instead of icpc for c++ part. The intel user need to compile as: [php] shell$ ./configure CC=icc CXX=icpc F77=ifort FC=ifort ... [/php] I wrote to openMPI mailing list, they told me thar is a icc problem but when I run a simple hello project it runs. Or it is an installation problem. I have installed intel fortran and intel c\c++ in the same default folder, is it correct? thanks
bernaske
New Contributor I
104 Views

okay this is correct, default the Intel installation program installs the c/c++ and the fortran compiler in he same folder. i have use this type of environment setting for dedicade setting the environment export PATH=$PATH:/opt/cuda-5.0:/usr/local/cuda-5.0/bin:/opt/intel/composer_xe_2013.1.117/bin/intel64:/opt/intel/composer_xe_2013.1.117/ipp/bin/intel64:/opt/composer_xe_2013.1.117/mkl/bin/intel64:/opt/intel/impi/4.1.0.024/intel64/bin export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/cuda-5.0/common/lib/linux/x86_64:/usr/local/cuda-5.0/lib:/usr/local/cuda-5.0/lib64:/opt/intel/composer_xe_2013.1.117/compiler/lib/intel64:/opt/intel/mkl/lib/intel64:/opt/intel/ipp/lib/intel64:/opt/intel/tbb/lib/intel64:/opt/intel/impi/4.1.0.024/intel64/lib export IPPROOT=/opt/intel/composer_xe_2013.1.117/ipp the IPPROOT is the setting for Integrated Performancd Primitive short IPP environment, i have include this settings in each .bashrc for any user, you can for modify as you need for each user other: this is the result from ./configure --p: linux-cuda:/ibm_supercomputing/openmpi-1.6.3 # ./configure --p configure: error: missing argument to --prefix linux-cuda:/ibm_supercomputing/openmpi-1.6.3 # i have with my settings no problems with the ICC and his components such as MKL, IPP the debugger IDB or the Profiler on my workstation i permanent use my CUDA SDK 5.0 + gcc-4.6.3 and the Intel C/C++ for performance critical standard c/c++ apps. tip: check after reboot your environment with follows: echo $PATH = info PATH settings echo $LD_LIBRARY_PATH = info LIB-PATH Settings when you find in both the settings for the Intel c/c++ and fortran then normally all works correct cheers Franz