Community
cancel
Showing results for 
Search instead for 
Did you mean: 
phily
Beginner
270 Views

mcpcom: No such file or directory

Hi,
Following the thread:

http://software.intel.com/en-us/forums/showthread.php?t=79182

I have downloaded the trial version of the Intel C/C++ XE 2011 for Mac OSX, and when executing

xiar -cru LIB_HPF.a HPF.o

After having compiled the objects as follows:

icc-ipo -cHPF.c

I get the following errors:

mcpcom: No such file or directory

xiar: error #10014: problem during multi-file optimization compilation (code 100)

xiar: error #10014: problem during multi-file optimization compilation (code 100)

I have tried to source compilervars.sh, as in the above thread, however this does not solve the issue.

I was looking at purchasing the C/C++ XE for Mac OSX. Is this issue specific with the demo version? and the Mac version? If not, would you have any suggestions?

0 Kudos
5 Replies
TimP
Black Belt
270 Views

If you have set the environment variables in accordance with the compilervars.sh script, mcpcom should appear on PATH (in the same directory as icc and xiar). In fact, icc would not have worked without it.
The trial version is identical to the full release version, except for expiration of the license and support.
If you want to make a library using the gnu ar tool, you would not set -ipo; then the mcpcom won't be needed to make a library from .o files.
Perhaps you didn't read between the lines; the source command would go like
source /opt/intel/composerxe-2011......../bin/compilervars.sh (for bash shell; .csh for tcsh shell)
phily
Beginner
270 Views

I ran the source command on the compilervars.sh in the composerxe folder and composerxe-2011 and composerxe-2011.2.142, I believe they are the same though....
My $PATH variable is:
/Developer/opt/intel/composerxe-2011.2.142/bin/intel64:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/texbin:/usr/X11/bin:/opt/intel/composerxe-2011.2.142/bin/intel64:/opt/intel/composerxe-2011.2.142/mpirt/bin/intel64:/opt/intel/composerxe-2011.2.142/bin:/opt/intel/composerxe-2011.2.142/bin/intel64:/opt/intel/composerxe-2011.2.142/mpirt/bin/intel64:/opt/intel/composerxe-2011.2.142/bin:/opt/intel/composerxe-2011.2.142/bin/intel64:/opt/intel/composerxe-2011.2.142/mpirt/bin/intel64:/opt/intel/composerxe-2011.2.142/bin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/texbin:/usr/X11/bin
Which contains the intel64 folder in which mcpcom is located.
I typed:mcpcom -help in BASH and got the following:
Intel C++ Compiler for applications running on Intel 64, Version 12.0.2.142 Build 20110112
Copyright (C) 1985-2011 Intel Corporation. All rights reserved.
catastrophic error: Compiler configuration problem encountered. The expected target architecture compiler is missing (unset != 12.0-intel64)
mcpcom -helpIntel C++ Compiler for applications running on Intel 64, Version 12.0.2.142 Build 20110112Copyright (C) 1985-2011 Intel Corporation. All rights reserved.catastrophic error: Compiler configuration problem encountered. The expected target architecture compiler is missing (unset != 12.0-intel64)
Thank you for your assistance.
Om_S_Intel
Employee
270 Views

Your icc environment seems corrupt!

If you installed the compiler using default then you can run the follwing command to setup icc environment:

$ source /opt/intel/composerxe/bin/compilervars.sh intel64
phily
Beginner
270 Views

... just figured it out. It's a setting on the MacOSX 10.6, simply. The OS needs to be booted in 64-bit mode (64-bit Kernel and Extensions)
However, why icc was still running although the compilervars were set to intel64 is a mystery to me.
Om_S_Intel
Employee
270 Views

Intel compiler is native compiler for Intel 64 iMAC. The compilervars script must check the OS. It could be a bug.
Reply