Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sqrt
Beginner
64 Views

occasional unresolved symbols at debug break

We experience the critical issue that the debugger sometimes cannot resolve most symbols of variables when breaking.
This mostly happens in STL iterator loops and nested loops. The full callstack is available though.
It is obvious that this is seriously hampering our productivity with the compiler.

compiler options used:
/c
/Od
_HAS_ITERATOR_DEBUGGING=0
_SECURE_SCL=0
_UNICODE
_VC80_UPGRADE=0x0710
/EHsc
/RTC1
/MT
/GS
/Gy
/arch:SSE2
/fp:strict
/fp:except
/W3
/nologo
/ZI
/Qwd1899
/FI
0 Kudos
5 Replies
sqrt
Beginner
64 Views

Oh and I forgot to mention that this issue is replicable wherever it occurs and that I am Visual Studio 2008.
sqrt
Beginner
64 Views

It is possible to work around this issue by declaring the loop index variable outside of the for-init-statement.
Is there a fix on the way?!
JenniferJ
Moderator
64 Views

Quoting - sqrt
It is possible to work around this issue by declaring the loop index variable outside of the for-init-statement.
Is there a fix on the way?!

Could you copy/paste some code snippets here? and the link error. If you could get a testcase, it would be really nice.

Thanks,
Jennifer
sqrt
Beginner
64 Views


Could you copy/paste some code snippets here? and the link error. If you could get a testcase, it would be really nice.

Thanks,
Jennifer

I did not manage to create a test app that replicates the problem.
The issue is not a linker error, but that the debugger is unable to resolve symbols for inspection at debug break in the Visual Studio IDE. Sorry if the terminology is wrong here.
64 Views

Hi,

in the meantime at least one similar error was fixed and is available in the last public release. I would assume that the described error not occur anymore. If I'm wrong, I'm happy to help investigating in this issue(having some code snippets would make it easier for me).

Alex