Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
137 Views

"Enable C++14/17 Support" options are missing in Visual Studio 2017 integration

Visual Studio 2017 integration of "Intel Parallel Studio XE 2018" shows only "Enable C++11 Support" option in project properties.

Project > Project Properties > Configuration Properties > C/C++ > Language [Intel C++] > Enable C++11 Support

"Enable C++14 Support" and "Enable C++17 Support" options are missing.

They can be enabled only by adding /Qstd:c++14 or /Qstd:c++17 to command line.

This issue was reported before for "Visual Studio 2015 integration" in the following link.

https://software.intel.com/en-us/forums/intel-c-compiler/topic/604805
 

0 Kudos
3 Replies
Highlighted
Beginner
137 Views

Yes, it's the same for VS2013/15.

From my testing, /Qstd=xxx does nothing under Windows. The same compiler features are available regardless of this compiler option.

For example, variadic templates and decltype(auto) returns, which are both C++14 features, compile just fine with /Qstd=c++11 (I'm not even sure why C++11 support is included in the GUI as you can't elect a "lesser" feature set...yes or no - it matters not). Under Windows, you get what you get as far as language features are concerned. I wished this feature worked as it would ease writing code for less-conformant compilers or cross-platform projects built with different language feature support.

0 Kudos
Highlighted
137 Views

FWIW on V17u4 (and maybe earlier),

On Linux, using C++14 and C++11, __cplusplus is set to a value less tan 201103L (I've resorted to redefining this).
On Windows, which documentation lists __cplusplus is not used, I cannot define it (gets error message as being compiler defined).

Jim Dempsey

0 Kudos
Highlighted
Moderator
137 Views

yes, it's true. Those should be added to the Language tab. I've filed a ticket for it. CMPLRS-45815

It can be work around as mentioned in the original posting. if you'd like to be notified when the fix is available, please file a ticket at Online Service Center

thanks,
Jennifer 

0 Kudos