Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Sen_X_
Beginner
117 Views

[randomly] xilib: : error #10014: problem during multi-file optimization compilation (code 1)

 

  ...
  
  target\VS2015\print_report_profiler.obj

  target\VS2015\instrument_stack.obj

  target\VS2015\print_report_stack.obj /qdiag-disable:"2415"

  Can't open file C:\Users\builder\AppData\Local\Temp\13448275tempfile2 for write

xilib: : error #10014: problem during multi-file optimization compilation (code 1) [filesystem\windows_amd64_icl\a_2015.vcxproj]

xilib: : error #10014: problem during multi-file optimization compilation (code 1) [filesystem\windows_amd64_icl\a_2015.vcxproj]

Done Building Project "filesystem\windows_amd64_icl\a_2015.vcxproj" (Build target(s)) -- FAILED.



Build FAILED.

Clues:

  1. Windows 7 64bits, MSVS 2015, C code, Intel Parallel Studio XE 2016 Intel 64.
  2. It happens randomly, starting from clean code every time.
  3. In 2010 and 2013, Intel forum mentioned similar problem, https://software.intel.com/en-us/forums/intel-c-compiler/topic/361884 and https://software.intel.com/pt-br/forums/intel-visual-fortran-compiler-for-windows/topic/289176.

Any suggestion to resolve it? Better if keep multi-file optimization enabled.

Thanks.

0 Kudos
1 Reply
Kittur_G_Intel
Employee
117 Views

Hi Sen,
Since I am not able to reproduce this issue on a similar platform it could be an isolated issue on your end. You can turn off multi-file ipo by the switch "/qipo-"  If you still insist that you need IPO then you should submit an issue in https://premier.intel.com support, so you can attach the project solution etc., to that issue as the content is secure and I can delete after reproducing the issue, appreciate much.
Thanks,
Kittur

Reply