Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
17 Views

unable to use icc, except setup the eviroment

I installed icc on my fedora 16 system, it seems succesful, but everytime I have to run source /opt/intel/composerxe/bin/compilervars.sh intel64, otherwise I'm not able to use icc. Anyone know what's wrong?
0 Kudos
4 Replies
Highlighted
New Contributor I
17 Views

Hi
For you helping , better, you must give before version of ICC and
version of GNU compiler that are operational on your system
(bash command line)

/opt/intel/bin/icc -v
or
/opt/intel/composerxe/bin/icc -v

gcc -v
Regards
0 Kudos
Highlighted
17 Views

Hi,
Yes you should set the compiler environment for each session of the terminal using source, This would set the compiler/debugger/libraries environment.

Thanks & Regards,
Sukruth H.V
0 Kudos
Highlighted
Black Belt
17 Views

The installation instructions mention the option of including the source compilervars command in your shell startup script.
0 Kudos
Highlighted
New Contributor I
17 Views

Hi
Object of my question about the version compiler:

Now, an change with Intel Compiler 13 beta , icc & icpc loader call sub-directory a level tree
in less back for unconditional path. using (../xxxx) , therefore, you can't move
loader is hosted on an other path that could pass default.
One way you like another to impose a positioning to entering....,
Maybe it's for better hide it's an sub compiler fronted only or it's to
lock call other library path alternatives.
The programmers are not stupid for not understand the true reason for this nail...


(This would set the compiler/debugger/libraries environment.)


With an true compiler , debugger is a choice optional that should be called as parameter
only voluntarily , by users i think. not imposed using the crafts , it's operational
by default possible from an sh declaration environment.
Regards
0 Kudos