Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
31 Views

unusual warning when linking with boost--ipo looking for dylib in nonexistent directory

I am compiling a C++ program under Mac OS 10.9.4 using icpc 14.0.1 (student version). I use several libraries I have built using icpc to avoid problems I have had when they were compiled with g++. During linking I get the following warning:

$ mpic++ -o dynamix-ga obj/initializer.o obj/main.o obj/mutator.o obj/objective.o obj/output.o obj/parser.o -ldynamix -lga-mpi -lsundials_cvode -lsundials_nvecserial -lboost_mpi -lboost_serialization -mkl -fopenmp
ipo: warning #11012: unable to find /Volumes/bpart/users/mstester/nightly/makebuild1/20131011_000000/dev/build_objs/efi2mac_d0p0flexlm/lib/libirng.dylib

My program runs correctly as far as I can tell, but I am wondering where this warning comes from--that path is not one I have on my computer, and it looks like one left over from building and testing the Intel installer package.

I have only noticed this warning since I started using boost.

Here are the outputs showing relevant environment variables:

$ echo $CXXFLAGS
 -O0 -Wall -std=c++11 -fopenmp -xHOST -no-prec-div -mkl -no-multibyte-chars
$ mpic++ -show

icpc -I/Users/andyras/bin/openmpi-1.8.1-intel-14.0.1/include -L/Users/andyras/bin/openmpi-1.8.1-intel-14.0.1/lib -lmpi_cxx -lmpi
$ locate libirng.dylib

/opt/intel/composer_xe_2013_sp1.1.103/compiler/lib/libirng.dylib

$ echo $CPATH

/opt/intel/composer_xe_2013_sp1.1.103/mkl/include:/opt/intel/composer_xe_2013_sp1.1.103/tbb/include:/Users/andyras/bin/boost-1.55.0-intel-14.0.1/include:/Users/andyras/bin/GAlib-mpi-openmpi-1.8.1-intel-14.0.1/include:/Users/andyras/bin/dynamix-2014-07-23-intel-14.0.1/include:/Users/andyras/bin/cvode-2.7.0-intel-14.0.1/include:/Users/andyras/bin/openmpi-1.8.1-intel-14.0.1/include:/opt/intel/composer_xe_2013_sp1.1.103/mkl/include:/opt/intel/composer_xe_2013_sp1.1.103/tbb/include

$ echo $LD_LIBRARY_PATH

/Users/andyras/bin/boost-1.55.0-intel-14.0.1/lib:/Users/andyras/bin/GAlib-mpi-openmpi-1.8.1-intel-14.0.1/lib:/Users/andyras/bin/dynamix-2014-07-23-intel-14.0.1/lib:/Users/andyras/bin/cvode-2.7.0-intel-14.0.1/lib:/Users/andyras/bin/openmpi-1.8.1-intel-14.0.1/lib

$ echo $DYLD_LIBRARY_PATH

/opt/intel/composer_xe_2013_sp1.1.103/compiler/lib:/opt/intel/composer_xe_2013_sp1.1.103/compiler/lib/intel64:/opt/intel/composer_xe_2013_sp1.1.103/ipp/../compiler/lib:/opt/intel/composer_xe_2013_sp1.1.103/ipp/lib:/opt/intel/composer_xe_2013_sp1.1.103/compiler/lib:/opt/intel/composer_xe_2013_sp1.1.103/mkl/lib:/opt/intel/composer_xe_2013_sp1.1.103/tbb/lib:/Users/andyras/bin/boost-1.55.0-intel-14.0.1/lib:/opt/intel/composer_xe_2013_sp1.1.103/compiler/lib:/opt/intel/composer_xe_2013_sp1.1.103/compiler/lib/intel64:/opt/intel/composer_xe_2013_sp1.1.103/ipp/../compiler/lib:/opt/intel/composer_xe_2013_sp1.1.103/ipp/lib:/opt/intel/composer_xe_2013_sp1.1.103/compiler/lib:/opt/intel/composer_xe_2013_sp1.1.103/mkl/lib:/opt/intel/composer_xe_2013_sp1.1.103/tbb/lib

 

0 Kudos
7 Replies
Highlighted
Employee
31 Views

Hi Andrew, this is indeed a strange warning and haven't seen before. I'll let you know as soon as I hear from the developers.

_Kittur

0 Kudos
Highlighted
Employee
31 Views

Hi Andrew,

Thanks for letting us know this strange warning. Yes, an issue was filed with our developer who is working on a fix which will be expected in the next 14.X update release. I'll keep you updated as soon as the release with the fix is out.The warning apparently seems to be from the object reader and should not have any side effects to your application/run.

_KIttur

0 Kudos
Highlighted
Employee
31 Views

Hi Andrew,
Just letting you know that this issue is fixed in the latest 15 update 3 version that you can download from the Intel Registration Center, thanks
_Kittur

0 Kudos
Highlighted
31 Views

Dear Kittur, sorry but I am using ifort version 15.0.4 on mac OS X El Capitan from composer_xe_2015 distribution (I guess it's version 2015 update 5 of ifort)? The problem is still here...

Hasn't it been fixed for this version ?

Thank's for your hints.

 

Daniel.

 

0 Kudos
Highlighted
Employee
31 Views

Hi Daniel,
Can you try to download the 2015 Update 6 (Build date: 24 Nov. 2015) from the Intel Registration Center and try out. The issue filed with the developers says as "fixed". Can you please check this release and let me know? Appreciate your help
Regards,
Kittur

0 Kudos
Highlighted
31 Views

Dear Kittur, thank's for the advice but to do this I have to renew my 2015 update 5 Licence, which I can't do right now...

So, happy to ear that it has been fixed for the lucky owners of update 6...

Best,

Daniel.

0 Kudos
Highlighted
Employee
31 Views

Thanks Daniel for your response. I hope you can upgrade to the current release in the near future. Please feel free to use to the forum to report any other issues you may bump into and help improve the product, appreciate much.

_Kittur

0 Kudos