Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Dimitry_N_Intel
Employee
104 Views

vectorization report in VS2015

Jump to solution

Hi , I just moved from Intel compiler 13.0 to Intel compiler 16.0 on VS2015 ,

using option /Qopt-report-phase=vec  /Qopt-report=2  to see in output window the result report , but result is nothing .

only if I set option "Interprocedural Optimization" to "No" I am getting result in .optrpt file .

 

Please advice how to get vectorization  report in output window in VS2015.

 

Thanks.

0 Kudos
1 Solution
TimP
Black Belt
104 Views

As no one responded, I'll point out that documented Windows version of those options uses : unlike linux which uses =.  It may also work without : = or space.  There is also advice at https://software.intel.com/en-us/articles/qvec-reportn-doesnt-work-with-qipo-in-the-ide about dealing with much older compilers which had a similar problem.

View solution in original post

2 Replies
TimP
Black Belt
105 Views

As no one responded, I'll point out that documented Windows version of those options uses : unlike linux which uses =.  It may also work without : = or space.  There is also advice at https://software.intel.com/en-us/articles/qvec-reportn-doesnt-work-with-qipo-in-the-ide about dealing with much older compilers which had a similar problem.

View solution in original post

Dimitry_N_Intel
Employee
104 Views

thanks

Reply