Community
cancel
Showing results for 
Search instead for 
Did you mean: 
sun_l_
New Contributor I
88 Views

x86_64-k1om-linux-ld: warning: xxx.so, needed by yyy.so, not found (try using -rpath or -rpath-link)

 

I use "icc -mmic" to compile it.

Why there are so maney warnings "x86_64-k1om-linux-ld: warning: xxx.so, needed by ../glib/.libs/libglib-2.0.so, not found"?

I'm sure ../glib/.libs/libglib-2.0.so exits.

The errors caused by that?

 

 

/bin/sh ../libtool  --tag=CC   --mode=link icc  -mmic -O3 -funroll-loops -opt-prefetch -Wall -I/usr/include -I/home/kwang/libsParsec3/include -L/home/kwang/libsParsec3/lib  -L/usr/lib64 -L/usr/lib -o gio-querymodules gio-querymodules.o ../glib/libglib-2.0.la ../gobject/libgobject-2.0.la ../gmodule/libgmodule-2.0.la libgio-2.0.la  

libtool: link: icc -mmic -O3 -funroll-loops -opt-prefetch -Wall -I/usr/include -I/home/kwang/libsParsec3/include -o .libs/gio-querymodules gio-querymodules.o  -L/home/kwang/libsParsec3/lib -L/usr/lib64 -L/usr/lib ../glib/.libs/libglib-2.0.so ../gobject/.libs/libgobject-2.0.so ../gmodule/.libs/libgmodule-2.0.so ./.libs/libgio-2.0.so /root/phi-energy/shared/parsec20150416/pkgs/libs/glib/src/gobject/.libs/libgobject-2.0.so /root/phi-energy/shared/parsec20150416/pkgs/libs/glib/src/gthread/.libs/libgthread-2.0.so -lpthread -lrt /root/phi-energy/shared/parsec20150416/pkgs/libs/glib/src/gmodule/.libs/libgmodule-2.0.so /root/phi-energy/shared/parsec20150416/pkgs/libs/glib/src/glib/.libs/libglib-2.0.so -lresolv -lz -Wl,-rpath -Wl,/home/wang/libsParsec3/lib

ipo: warning #11010: file format not recognized for /lib64/libpthread.so.0
ipo: warning #11010: file format not recognized for /usr/lib64/librt.so
ipo: warning #11010: file format not recognized for /usr/lib64/libresolv.so
ipo: warning #11010: file format not recognized for /usr/lib64/libm.so
ipo: warning #11010: file format not recognized for /lib64/libc.so.6
ipo: warning #11010: file format not recognized for /lib64/ld-linux-x86-64.so.2
ipo: warning #11010: file format not recognized for /usr/lib64/libdl.so
ipo: warning #11010: file format not recognized for /lib64/libc.so.6
ipo: warning #11010: file format not recognized for /lib64/ld-linux-x86-64.so.2
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libpthread.so when searching for -lpthread
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libpthread.a when searching for -lpthread
x86_64-k1om-linux-ld: skipping incompatible /usr/lib/libpthread.so when searching for -lpthread
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/librt.so when searching for -lrt
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/librt.a when searching for -lrt
x86_64-k1om-linux-ld: skipping incompatible /usr/lib/librt.so when searching for -lrt
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libresolv.so when searching for -lresolv
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libresolv.a when searching for -lresolv
x86_64-k1om-linux-ld: skipping incompatible /usr/lib/libresolv.so when searching for -lresolv
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libm.so when searching for -lm
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libm.a when searching for -lm
x86_64-k1om-linux-ld: skipping incompatible /usr/lib/libm.so when searching for -lm
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libc.so when searching for -lc
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libc.a when searching for -lc
x86_64-k1om-linux-ld: skipping incompatible /usr/lib/libc.so when searching for -lc
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libdl.so when searching for -ldl
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libdl.a when searching for -ldl
x86_64-k1om-linux-ld: skipping incompatible /usr/lib/libdl.so when searching for -ldl
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libc.so when searching for -lc
x86_64-k1om-linux-ld: skipping incompatible /usr/lib64/libc.a when searching for -lc
x86_64-k1om-linux-ld: skipping incompatible /usr/lib/libc.so when searching for -lc
x86_64-k1om-linux-ld: warning: libimf.so, needed by ../glib/.libs/libglib-2.0.so, not found (try using -rpath or -rpath-link)
x86_64-k1om-linux-ld: warning: libsvml.so, needed by ../glib/.libs/libglib-2.0.so, not found (try using -rpath or -rpath-link)
x86_64-k1om-linux-ld: warning: libirng.so, needed by ../glib/.libs/libglib-2.0.so, not found (try using -rpath or -rpath-link)
x86_64-k1om-linux-ld: warning: libintlc.so.5, needed by ../glib/.libs/libglib-2.0.so, not found (try using -rpath or -rpath-link)
./.libs/libgio-2.0.so: undefined reference to `is_selinux_enabled'
./.libs/libgio-2.0.so: undefined reference to `getfilecon_raw'
./.libs/libgio-2.0.so: undefined reference to `setfilecon_raw'
./.libs/libgio-2.0.so: undefined reference to `fgetfilecon_raw'
./.libs/libgio-2.0.so: undefined reference to `lgetfilecon_raw'
./.libs/libgio-2.0.so: undefined reference to `freecon'
make[4]: *** [gio-querymodules] Error 1

 

 

0 Kudos
0 Replies
Reply