Community
cancel
Showing results for 
Search instead for 
Did you mean: 
peng_z_4
Beginner
149 Views

xilib crash

Hi everybody,

i have a c project created by vs2013, and i have intel parallel studio 2015 installed.

when i switch to intel c++ complier, the project failed to build and reports:

"error MSB6006: "xilib.exe" exited with code -1073741819."

following is the details:

 问题事件名称: APPCRASH
  应用程序名: xilink.exe
  应用程序版本: 0.0.0.0
  应用程序时间戳: 55c2d55f
  故障模块名称: xilink.exe
  故障模块版本: 0.0.0.0
  故障模块时间戳: 55c2d55f
  异常代码: c0000005
  异常偏移: 00000000000102e5
  OS 版本: 6.1.7601.2.1.0.256.1
  区域设置 ID: 2052
  其他信息 1: deae
  其他信息 2: deae8466249636a96c00183fb6617609
  其他信息 3: a391
  其他信息 4: a391856a550db3984a67a8b9271c3b96
 

0 Kudos
17 Replies
peng_z_4
Beginner
149 Views

can anybody help to locate the problem?  thanks!

Kittur_G_Intel
Employee
149 Views

Hi Peng,

Can you try the latest 2016 Update 1 release available from the Intel Registration Center?
In the meantime, under the MSVS IDE, disable offload under: Configuration Properties >  C/C++ > Code Generation [Intel C++] > Offload Constructs and set the field to None (/Qoffload:none)  and try again and see if the issue still exists?

_Kittur

Kittur_G_Intel
Employee
149 Views

Peng, since I am not able to reproduce the issue can you attach the copy of the project solution so I can try on my system?  Or at least the objects and libraries used otherwise?

_Kittur

 

peng_z_4
Beginner
149 Views

Kittur Ganesh (Intel) wrote:

Hi Peng,

Can you try the latest 2016 Update 1 release available from the Intel Registration Center?
In the meantime, under the MSVS IDE, disable offload under: Configuration Properties >  C/C++ > Code Generation [Intel C++] > Offload Constructs and set the field to None (/Qoffload:none)  and try again and see if the issue still exists?

_Kittur

hi _Kittur, i tried '(/Qoffload:none) ', but the problem still exists.

the project are large and private, so i can not attach them.  and now, i will create another program and try to reproduce the problem.

 

JenniferJ
Moderator
149 Views

What is the version of Intel C++ compiler you're using?

Open the VS's Help > About, you will see.

can you attach the build log to start with?

thanks,

Jennifer

Kittur_G_Intel
Employee
149 Views

Hi Peng, I am off tomorrow and Jennifer should be able to help you out (thanks Jennifer!).  Yes, a reproducer is needed as it's hard to investigate without one, so thanks for trying to make one.

_Kittur

peng_z_4
Beginner
149 Views

Kittur Ganesh (Intel) wrote:

Hi Peng, I am off tomorrow and Jennifer should be able to help you out (thanks Jennifer!).  Yes, a reproducer is needed as it's hard to investigate without one, so thanks for trying to make one.

_Kittur

thanks, _Kittur

peng_z_4
Beginner
149 Views

Jennifer J. (Intel) wrote:

What is the version of Intel C++ compiler you're using?

Open the VS's Help > About, you will see.

can you attach the build log to start with?

thanks,

Jennifer

hi Jennifer, i am using Intel C++ 15.0.

i think i found something, look at the following macros:

when i choose to use intel c++ in MSVC IDE by  'Intel compiler -> use Intel c++', it always prints "it is msvc.",

i think the _MSC_VER should not be predefined if i choose intel c++,  am i wrong?

#if defined(_MSC_VER)
    printf("it is msvc.\n");
#elif defined(__INTEL_COMPILER)
    printf("it is intel.\n");
#else
    printf("hell.\n");
#endif

peng_z_4
Beginner
149 Views

i created one very simple project that can easily reproduce my problem.

it happens only with the 'release' build.

1>------ Rebuild All started: Project: ConsoleApplication5, Configuration: Release Win32 ------
1>  Source.c
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Platforms\Win32\PlatformToolsets\Intel C++ Compiler XE 15.0\Toolset.targets(1428,5): error MSB6006: "xilib.exe" exited with code -1073741819.
========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========

check the attachment please.

Kittur_G_Intel
Employee
149 Views

Thanks Peng, I'll try the attached reproducer and file the issue with our developers. I'll keep you updated, appreciate much.

_Kittur

Kittur_G_Intel
Employee
149 Views

Hi Peng,
I've filed the issue with our developers and will keep you updated as soon as the release with the fix is out. Appreciate your patience till then, thanks.

_Kittur

Melanie_B_Intel
Employee
149 Views

peng z. wrote:

Quote:

...

hi Jennifer, i am using Intel C++ 15.0.

i think i found something, look at the following macros:

when i choose to use intel c++ in MSVC IDE by  'Intel compiler -> use Intel c++', it always prints "it is msvc.",

i think the _MSC_VER should not be predefined if i choose intel c++,  am i wrong?

#if defined(_MSC_VER)
    printf("it is msvc.\n");
#elif defined(__INTEL_COMPILER)
    printf("it is intel.\n");
#else
    printf("hell.\n");
#endif

Peng, In our Windows compiler, it's expected that both _MSC_VER and __INTEL_COMPILER will be defined. Test for __INTEL_COMPILER before testing for MSC_VER.

--Melanie

JenniferJ
Moderator
149 Views

This is not a compiler bug, it's an IDE integration issue.

The "#ifdef" code does not matter here. But Melanie is correct, if you want to have specific code to be compiled by Intel Compiler, you should use "__INTEL_COMPILER_UPDATE" instead. see this page for the macros that you can use - https://software.intel.com/en-us/node/514528

Jennifer

peng_z_4
Beginner
149 Views

thx, _Kittur, Melanie and Jennifer,

it's my mistake, i have a wrong idea about the macro ' __INTEL_COMPILER '.

but, the project in my attachment still causes 'xilink.exe' to crash in the release builds, it is a c lib that contains a single empty main function , and there is no macro defined.

can you guide me what i am wrong? thanks! 

 

Kittur_G_Intel
Employee
149 Views

Hi Peng,
As a workaround in the meantime can you try using the command line instead of using the IDE and let us know?
Thanks,
Kittur

peng_z_4
Beginner
149 Views

Kittur Ganesh (Intel) wrote:

Hi Peng,
As a workaround in the meantime can you try using the command line instead of using the IDE and let us know?
Thanks,
Kittur

Hi Kittur,

Could you reproduce the crash in my attached project?

i am not familiar with the command line tools. could you please tell me how ?

Kittur_G_Intel
Employee
149 Views

Hi Peng, 
Nope, I couldn't reproduce the crash but your attached solution ran fine with debug and release modes per-se on my system. I filed the issue to another similar issue that was filed before but not with your attached reproducer which was successful on my system. 

That said,  to invoke the command line you can do:

1) Open a command line build environment window by going to:  start menu > all programs > Intel Parallel studio 2015..... > compiler update 1 for x64 VS2015.

2) You'll see the command line window pop up after 1) and the environment for the Intel Compiler is already set in  that window and ready for compile.

3) %icl /V     will output the compiler version and build info

4) Now compile your c/++ file accordingly   "%icl  <options>  <c/c++ files> "   where options can be whatever options you want to use for compilation.

Hope the above helps, thx. Also, you can download the latest 2016 Update 1 release of the product and try it out as well.


_Kittur

 

Reply