Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Frank_A_
Beginner
198 Views

xilink error

Hi,

after complete new installation of visual studio 2015 and composer 2016 sp1 on a Windows 10 pro I get the following error of xilink:

C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\x64\PlatformToolsets\Intel C++ Compiler 16.0\Toolset.targets(1090,5): error MSB6006: "xilink.exe" .. Code -1073741701

What can I do?

Frank

 

 

0 Kudos
8 Replies
TimP
Black Belt
198 Views

You may wish to see if /verbosity switch can give a reason (such as output file inaccessible due to folder permissions or locks).

Frank_A_
Beginner
198 Views

OK. I checked that. The /verbosity option is active. But no additional messages are shown. Strange is also that I can compile and link the project in Visual studio without 'Intel Settings' as 'Visual C++'.

 

Kittur_G_Intel
Employee
198 Views

Hi Frank,
Can you verify the version of Intel C++ compiler you're using? Open the VS's Help > About, you will see the info. Also, since you mention the install was successful so I assume the error you're getting is when you compile/link an app? If so, you can go to tools->options->project and solution->Build and Run-> Build output verbosity (set to detailed) and see if you can get additional info on the reason?

Can you attach the build log or the test reproducer to investigate further? Additionally, can you try command line compilation as well and see if that works by opening a command line build environment window by going to:  start menu > all programs > Intel Parallel studio 2016..... > compiler update....for x64 VS2016....

Thx,
_Kittur

 

 

Frank_A_
Beginner
198 Views

Hi Kittur,

for complete version Information look at the attached picture.
Yes, the error occured during linking an application. I attached the LOG of Visual Studio too.

Next: I try to use linking from command line. Surprise. It works. I used the same parameter like Visual Studio.

Thanks

Frank

Frank_A_
Beginner
198 Views

 

.. here are the attachments.

F.

Kittur_G_Intel
Employee
198 Views

Hi Frank,
Can you attach the project solution or any small reproducer as with the attached log it wasn't possible to identify the issue. Appreciate your help.
_Kittur

Frank_A_
Beginner
198 Views

Hi Kittur,


thank you for your reply. Yesterday I had time and I wanted prepare a simple project for reproducing the issue outside our complete project environment. During this work I had some trouble on this special PC based on setting of older and newer Visual Studio version (2010, 2013, 2015) and older and newer Windows SDK's. I found that there was a chaotic situation. Then I uninstalled all Windows SDK and I tried to clear all forgetten settings. After that I installed SDK 10 again. Together with this step I cleared all project settings according to the various SDK's. OK - the result: The xilink issue does not longer appear.


Thank you for your help


Frank

 

 

Kittur_G_Intel
Employee
198 Views

Hi Frank,
      Great to hear from you that the issue is finally resolved at your end. Appreciate your confirmation and for your patience through this.
_Kittur

Reply