Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
278 Views

请教几个Windows版客户端SDK 的问题

1、是否只能运行在32位的机器上

2、看需要如下几个模块,请问有具体的版本要求吗?对VS的版本有要求吗?

 * Qt
 * Boost
 * socketio.cpp(Optional)
 * ffmpeg(Optional)

Tags (2)
0 Kudos
5 Replies
Highlighted
278 Views

你好

1.可以运行在64位机子上。由于运行库是32位的,请注意链接和编译工具的配置。

2.VS需要使用2015.我目前使用的QT版本是5.6,boost是1.61,Socket.IO CPP是1.6.1.

0 Kudos
Highlighted
Beginner
278 Views

谢谢,“可以运行在64位机子上。由于运行库是32位的,请注意链接和编译工具的配置”,请问这个具体是怎么配置的?

0 Kudos
Highlighted
278 Views

比如Target Machine应该选MachineX86, Platform选win32.

0 Kudos
Highlighted
Beginner
278 Views

编译windows版的客户端出现如下错误,请问sioclient.lib怎么加入到项目中?

>LINK : fatal error LNK1181: 无法打开输入文件“sioclient.lib”

0 Kudos
Highlighted
Beginner
278 Views

我觉得应该是socketio没用好,请问这个改怎么添加进去,没有说明文档

[socketio.cpp](https://github.com/socketio/socket.io-client-cpp.git)

0 Kudos