Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2 Views

How to deploy MCU server on AWS ec2 instance?

After research and trying to deploy MCU server on aws for days.

Still can't successfully deploy MCU server on aws ex2 instance.

Reference to some comments from intel crew. Seems that you had tried to deploy server on aws.

If so, we are glad to know how could we deploy server on it.

To be honest, the documents are way too simple and crude....

Tags (2)
0 Kudos
4 Replies
Highlighted
Beginner
2 Views

Hello Lin,

Hello Lin,

I believe that first you deployed MCU server in your local system successfully, before trying to deploy in AWS. You need to do some modifications as below to deploy MCU server in AWS:

1) You must create ICE server (STUN/TURN) in an instance
2) You need to do the below modifications along with the points that had given in the documentation:

* Give the below values in the [internal] section of audio_agent/agent.toml, recording_agent/agent.toml, sip_agent/agent.toml, streaming_agent/agent.toml, video_agent/agent.toml, analytics_agent/agent.toml, webrtc_agent/agent.toml files:
    [internal]
    ip_address = "10.1.1.110"    # Private IP address of MCU server
    network_interface = "ens5"

* Give the below value in the [portal] section of portal/portal.toml file:
    [portal]
    #hostname = "" #default: ""
    ip_address = "3.1.33.12"    # Elastic IP address of MCU server

* Give the below value in the [webrtc] section of webrtc_agent/agent.toml file:
    [webrtc]
    network_interfaces = [{name = "ens5", replaced_ip_address = "3.1.33.12"}]
    stunport = 3478            # Port number of STUN server
    stunserver = "10.1.1.112"    # Private IP address of STUN server

Please make sure to add the private addresses of MCU and ICE server in /etc/hosts file in both the servers. Also make sure to follow the firewall rules as explained in the documentation.

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Beginner
2 Views

Morning~ Chandramouli P

Morning~ Chandramouli P

As you said in the comments. Seems that I need to lauch 2 instances?
After adjusted some configuration according to your comment. Finally start without error and got a sample room but the sample room only shows localStream. Generally, the sample room should perform a mixed room right?

And how can I add the private addresses of MCU and ICE server in /etc/hosts file in both the servers?

0 Kudos
Highlighted
Beginner
2 Views

Hello Lin,

Hello Lin,

You no need to launch two instances. You can deploy ICE and MCU servers in a single instance. In that case, you can give "localhost" to "stunserver" parameter. But, make sure about port conflicts.

If you make modifications as I suggested, you should see remote stream also. Please double check your configuration. As you said, the sample application runs using MCU (Mixed) mechanism.

Below is the example of /etc/hosts file:

$ nano /etc/hosts
Private IP address    Private DNS or Hostname

After saving the file, restart the network service or restart the server to take effect.

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Beginner
2 Views

Hi! Chandramouli,

Hi! Chandramouli,

I've solved the problem by enable UDP port in security group and configure max/min port in WebRTC's agent.toml file.

Thanks so much for your detailed explanation!

0 Kudos