Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
85 Views

ICS installation on CentOS 7.6

Hi everyone,

I tried to deploying MCU on our server but found that the MCU codebase is deprecated and the libraries are not compatible with CentOS 7.6. Thus, we cannot continue with the deployment and installation of MCU on our server. Can anyone please help me to install the ICS server on CentOS 7.4

Thanks in advance.

Tags (2)
0 Kudos
15 Replies
Highlighted
85 Views

Our 4.1 released package is fully tested on CentOS 7.4. for install ICS server on CentOS 7.4, please refer to our conference server guide and check installation chapter.

0 Kudos
Highlighted
Beginner
85 Views

Hello,

I must apologies here because in my last question I wanted to ask "Can anyone please help me to install the ICS server on CentOS 7.6" instead of CentOS 7.4 . Can you help me on how to install ICS server on CentOS 7.6 because it seems to be giving me some errors on installation.

Thanks in advance.

0 Kudos
Highlighted
Beginner
85 Views

Hello Rathi,

We successfully deployed MCU server in CentOS 7.6. Are you trying to deploy in your local network environment or in cloud? What errors you are getting?

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Beginner
85 Views

Hi Chandramouli,

While executing start-all.sh we are getting the below error,
but all process are started, when opening the console we are unable to process the video.

If I install GLIBC_2.18 on the server, I am unable to execute any command on the server, so i need to revert back.
Server OS- Centos 7.6

starting audio-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-audio-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
conference-agent running as process 51470.
starting recording-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-recording-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting sip-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-sip-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting streaming-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-streaming-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting video-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-video-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting webrtc-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-webrtc-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)

0 Kudos
Highlighted
Beginner
85 Views

Hello,

This must be an issue with development libraries. Please execute the below command and try again:

yum groupinstall core -y
yum groupinstall base -y
yum groupinstall "Development Tools" -y
yum groupinstall "Debugging Tools" -y
yum install gcc ncurses-devel libtermcap-devel kernel-devel gcc-c++ newt-devel zlib-devel -y unixODBC-devel libtool make openssl-devel -y

By the way, you must tell your environment. Are you trying to deploy in your local network environment or in cloud?

Thank you.

Best Regards,
Chandramouli.

0 Kudos
Highlighted
Beginner
85 Views

Hi Chandramauli,

Thanks for your reply but I'm still getting the same error even after applying all your provided steps. You can find my errors below :-

starting recording-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-recording-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting sip-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-sip-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting streaming-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-streaming-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting video-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-video-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting webrtc-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-webrtc-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting management-console, stdout -> /home/appinv/develop/uChat_ICS_ORIG/l

 

I am installing the ICS server on my local network environment.

Best Regards,

Shubham Rathi

0 Kudos
Highlighted
Employee
85 Views

1. Check the GLIBC version on your environment to see why it's not found

2. Remove the file "libstdc++.so.6" in the MCU package's "xxx_agent/lib" directory to have a try. This let the program use system library.

0 Kudos
Highlighted
Beginner
85 Views

Hi team,

I apologies for my wrong question. Actually, this installation process via 'bin/init-all.sh' command was done successfully. This error was occurred using the execution of 'bin/start-all.sh' command, all the services are stated but they shows the error below.

starting recording-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-recording-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting sip-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-sip-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting streaming-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-streaming-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting video-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-video-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting webrtc-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-webrtc-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting management-console, stdout -> /home/appinv/develop/uChat_ICS_ORIG/l

Now while opening management console on browser I am able to login, but when I am running https://x.x.x.x:3004 url, I am unable to get back my video feedback.
The same is working with Ubuntu 16.04

I just want to know that MCU server is supported with the Centos 7.6 or new release, if yes than please share the solution for the same.

Regards,

Shubham Rathi

0 Kudos
Highlighted
Employee
85 Views

The Centos package is different from Ubuntu package. Make sure you use the Centos package instead of the Ubuntu one.

By the way, standard centos 7.6 should work

0 Kudos
Highlighted
Beginner
85 Views

Hi Li C,

we have used centos package for centos7.6 server but still getting same error.

please provide solution if we have.

Regards,

Tanuj Kumar

0 Kudos
Highlighted
Employee
85 Views

You can have a try, remove following files in package directory:

(webrtc_agent | video_agent | audio_agent | recording_agent | streaming_agent)/lib/libstdc++.so.6

0 Kudos
Highlighted
Beginner
85 Views

Hi Li C,

Now I am getting below error after removing /lib/libstdc++.so.6.

bin/start-all.sh
starting nuve, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-nuve.stdout
starting cluster-manager, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-cluster-manager.stdout
2019-01-29 15:09:59.310  - INFO: AmqpClient - Connecting to rabbitMQ server OK, hostPort: { host: 'localhost', port: 5672 }
2019-01-29 15:09:59.317  - INFO: Main - Cluster manager up! id: 725572507
2019-01-29 15:09:59.317  - INFO: ClusterManager - Run as candidate.
2019-01-29 15:09:59.512  - INFO: ClusterManager - Run as master.
2019-01-29 15:09:59.518  - INFO: ClusterManager - Cluster manager is in service as master!
starting audio-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-audio-agent.stdout
2019-01-29 15:10:00.000  - INFO: AmqpClient - Connecting to rabbitMQ server OK, hostPort: { host: 'localhost', port: 5672 }
2019-01-29 15:10:00.015  - INFO: ErizoAgent - audio agent join cluster ok.
2019-01-29 15:10:00.025  - INFO: ClusterWorker - Join cluster woogeen-cluster OK.
2019-01-29 15:10:00.026  - INFO: ErizoAgent - Node audio-a002b38f552639e47862@10.21.67.14_0 is closed on unexpected code: 1
2019-01-29 15:10:00.029  - INFO: ErizoAgent - Node audio-a002b38f552639e47862@10.21.67.14_1 is closed on unexpected code: 1
2019-01-29 15:10:00.034  - INFO: ErizoAgent - Node audio-a002b38f552639e47862@10.21.67.14_2 is closed on unexpected code: 1
2019-01-29 15:10:00.037  - INFO: ErizoAgent - Node audio-a002b38f552639e47862@10.21.67.14_3 is closed on unexpected code: 1
2019-01-29 15:10:00.041  - INFO: ErizoAgent - Node audio-a002b38f552639e47862@10.21.67.14_4 is closed on unexpected code: 1
2019-01-29 15:10:00.043  - INFO: ErizoAgent - as rpc server ok.
2019-01-29 15:10:00.043  - INFO: ErizoAgent - Node audio-a002b38f552639e47862@10.21.67.14_5 is closed on unexpected code: 1
starting conference-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-conference-agent.stdout
2019-01-29 15:10:01.121  - INFO: AmqpClient - Connecting to rabbitMQ server OK, hostPort: { host: 'localhost', port: 5672 }
2019-01-29 15:10:01.137  - INFO: ErizoAgent - conference agent join cluster ok.
2019-01-29 15:10:01.147  - INFO: ClusterWorker - Join cluster woogeen-cluster OK.
2019-01-29 15:10:01.162  - INFO: ErizoAgent - as rpc server ok.
2019-01-29 15:10:01.163  - INFO: ErizoAgent - as monitoring target ok.
starting recording-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-recording-agent.stdout
node: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by ./lib/libstdc++.so.6)
starting sip-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-sip-agent.stdout
2019-01-29 15:10:03.306  - INFO: AmqpClient - Connecting to rabbitMQ server OK, hostPort: { host: 'localhost', port: 5672 }
2019-01-29 15:10:03.320  - INFO: ErizoAgent - sip agent join cluster ok.
2019-01-29 15:10:03.329  - INFO: ClusterWorker - Join cluster woogeen-cluster OK.
2019-01-29 15:10:03.331  - INFO: ErizoAgent - Node sip-a7a6dc06429c64703b13@10.21.67.14_0 is closed on unexpected code: 1
2019-01-29 15:10:03.333  - INFO: ErizoAgent - Node sip-a7a6dc06429c64703b13@10.21.67.14_1 is closed on unexpected code: 1
2019-01-29 15:10:03.336  - INFO: ErizoAgent - Node sip-a7a6dc06429c64703b13@10.21.67.14_2 is closed on unexpected code: 1
2019-01-29 15:10:03.339  - INFO: ErizoAgent - Node sip-a7a6dc06429c64703b13@10.21.67.14_3 is closed on unexpected code: 1
2019-01-29 15:10:03.341  - INFO: ErizoAgent - Node sip-a7a6dc06429c64703b13@10.21.67.14_4 is closed on unexpected code: 1
2019-01-29 15:10:03.343  - INFO: ErizoAgent - Node sip-a7a6dc06429c64703b13@10.21.67.14_5 is closed on unexpected code: 1
2019-01-29 15:10:03.347  - INFO: ErizoAgent - Node sip-a7a6dc06429c64703b13@10.21.67.14_6 is closed on unexpected code: 1
starting streaming-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-streaming-agent.stdout
2019-01-29 15:10:04.430  - INFO: AmqpClient - Connecting to rabbitMQ server OK, hostPort: { host: 'localhost', port: 5672 }
2019-01-29 15:10:04.448  - INFO: ErizoAgent - streaming agent join cluster ok.
2019-01-29 15:10:04.458  - INFO: ClusterWorker - Join cluster woogeen-cluster OK.
2019-01-29 15:10:04.459  - INFO: ErizoAgent - Node streaming-b00cf251866188cdc069@10.21.67.14_0 is closed on unexpected code: 1
2019-01-29 15:10:04.462  - INFO: ErizoAgent - Node streaming-b00cf251866188cdc069@10.21.67.14_1 is closed on unexpected code: 1
2019-01-29 15:10:04.465  - INFO: ErizoAgent - Node streaming-b00cf251866188cdc069@10.21.67.14_2 is closed on unexpected code: 1
2019-01-29 15:10:04.469  - INFO: ErizoAgent - Node streaming-b00cf251866188cdc069@10.21.67.14_3 is closed on unexpected code: 1
2019-01-29 15:10:04.472  - INFO: ErizoAgent - Node streaming-b00cf251866188cdc069@10.21.67.14_4 is closed on unexpected code: 1
2019-01-29 15:10:04.475  - INFO: ErizoAgent - Node streaming-b00cf251866188cdc069@10.21.67.14_5 is closed on unexpected code: 1
2019-01-29 15:10:04.478  - INFO: ErizoAgent - Node streaming-b00cf251866188cdc069@10.21.67.14_6 is closed on unexpected code: 1
starting video-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-video-agent.stdout
2019-01-29 15:10:05.558  - INFO: AmqpClient - Connecting to rabbitMQ server OK, hostPort: { host: 'localhost', port: 5672 }
2019-01-29 15:10:05.579  - INFO: ErizoAgent - video agent join cluster ok.
2019-01-29 15:10:05.590  - INFO: ClusterWorker - Join cluster woogeen-cluster OK.
2019-01-29 15:10:05.591  - INFO: ErizoAgent - Node video-4e14d15d19ebba992c1a@10.21.67.14_0 is closed on unexpected code: 1
2019-01-29 15:10:05.595  - INFO: ErizoAgent - Node video-4e14d15d19ebba992c1a@10.21.67.14_1 is closed on unexpected code: 1
2019-01-29 15:10:05.599  - INFO: ErizoAgent - Node video-4e14d15d19ebba992c1a@10.21.67.14_2 is closed on unexpected code: 1
2019-01-29 15:10:05.602  - INFO: ErizoAgent - Node video-4e14d15d19ebba992c1a@10.21.67.14_3 is closed on unexpected code: 1
2019-01-29 15:10:05.606  - INFO: ErizoAgent - Node video-4e14d15d19ebba992c1a@10.21.67.14_4 is closed on unexpected code: 1
2019-01-29 15:10:05.609  - INFO: ErizoAgent - Node video-4e14d15d19ebba992c1a@10.21.67.14_5 is closed on unexpected code: 1
2019-01-29 15:10:05.613  - INFO: ErizoAgent - Node video-4e14d15d19ebba992c1a@10.21.67.14_6 is closed on unexpected code: 1
starting webrtc-agent, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-webrtc-agent.stdout
2019-01-29 15:10:06.666  - INFO: AmqpClient - Connecting to rabbitMQ server OK, hostPort: { host: 'localhost', port: 5672 }
2019-01-29 15:10:06.688  - INFO: ErizoAgent - webrtc agent join cluster ok.
2019-01-29 15:10:06.719  - INFO: ClusterWorker - Join cluster woogeen-cluster OK.
2019-01-29 15:10:06.729  - INFO: ErizoAgent - as rpc server ok.
2019-01-29 15:10:06.730  - INFO: ErizoAgent - Node webrtc-30e808b9613bdc52a089@10.21.67.14_0 is closed on unexpected code: 1
2019-01-29 15:10:06.738  - INFO: ErizoAgent - Node webrtc-30e808b9613bdc52a089@10.21.67.14_1 is closed on unexpected code: 1
2019-01-29 15:10:06.744  - INFO: ErizoAgent - Node webrtc-30e808b9613bdc52a089@10.21.67.14_2 is closed on unexpected code: 1
2019-01-29 15:10:06.747  - INFO: ErizoAgent - Node webrtc-30e808b9613bdc52a089@10.21.67.14_3 is closed on unexpected code: 1
2019-01-29 15:10:06.751  - INFO: ErizoAgent - Node webrtc-30e808b9613bdc52a089@10.21.67.14_4 is closed on unexpected code: 1
2019-01-29 15:10:06.756  - INFO: ErizoAgent - Node webrtc-30e808b9613bdc52a089@10.21.67.14_5 is closed on unexpected code: 1
starting management-console, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-management-console.stdout
Start management-console HTTP server
starting portal, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-portal.stdout
starting sip-portal, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-sip-portal.stdout
starting app, stdout -> /home/appinv/develop/uChat_ICS_ORIG/logs/woogeen-app.stdout
 

0 Kudos
Highlighted
Employee
85 Views

1. Run the command "ldd --version" to see which C library version does your system use.

2. Run the command "ldd -r -v libstdc++.so.6" and show us the result.

0 Kudos
Highlighted
Beginner
85 Views

Hi LI c,

please find result of above command..

[root@localhost appinv]# ldd --version
ldd (GNU libc) 2.17
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.
[root@localhost appinv]# ldd -r -v libstdc++.so.6
ldd: ./libstdc++.so.6: No such file or directory

0 Kudos
Highlighted
Employee
85 Views

Hi, kumar, tanuj

It seems that you were trying to run the Ubuntu MCU on CentOS. Please double check that you downloaded the right OS version of package.

0 Kudos