Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1141 Discussions

IOS OWT client stop sending stream with IOS version 14.7.1

Etreta
Beginner
1,137 Views

Hello

Maybe someone faced with such problem - I have project based on OWT/Swift that publish stream on OWT server. It works fine but when on new device (iPhone 12 mini) I upgrade IOS to 14.7.1 (latest)  my application stop sending stream. I have no any error messages. It just not sending it at all. I'm sure that it may connect with some network restrictions etc.. but not find yet..

 

Maybe someone have similar issue?

0 Kudos
9 Replies
K-OS
Beginner
1,094 Views

Hi!

We are facing the same problem. This seems to be an issue for others as well:
https://stackoverflow.com/questions/68711339/stream-owt-app-not-streaming-after-ios-update-to-14-7-1

Were you able to fix it?

 

Cheers!

Etreta
Beginner
1,086 Views

Yes. This is a bug in WebRTC that includes in Intel_CS_WebRTC_v4.3.1 pack - it includes WebRTC version from 2017 and that bug was fixed in 2018 releases. 

https://bugs.chromium.org/p/webrtc/issues/detail?id=9134 - here

Don't know about your situation but for me it helps.

 

K-OS
Beginner
1,080 Views

Hi Etreta,

thanks for your quick response! This old WebRTC version is still part of the OWT iOS client (v. 5.x)? Changing the Codec to VP8 changed anything. Still the same problem...

Etreta
Beginner
1,065 Views

Do you have binary release of OWT IOS v 5.x? Or you compile it from source?

K-OS
Beginner
1,059 Views

We are testing the current binary release (v5.0), as we had some ssl related runtime errors when using the compiled version. The binary version of v4.3.1 is also not working for us...

Etreta
Beginner
1,046 Views

Could you share release? I can't find it yet - want to try it also.

Did your stream published before 14.7.1 IOS version?

Did you try downgrade resolution of published stream? For example 1280x720?

K-OS
Beginner
1,032 Views

You can download the latest release here:

https://software.intel.com/content/www/us/en/develop/tools/webrtc-sdk.html

 

Did your stream published before 14.7.1 IOS version?
- Nope, we just started the developing...

Did you try downgrade resolution of published stream? For example 1280x720?
- We tried different resolutions... regarding the logs, we have pretty much the same issue like this dude:
https://stackoverflow.com/questions/68711339/stream-owt-app-not-streaming-after-ios-update-to-14-7-1

Etreta
Beginner
1,013 Views

This is my topic)) 

About logs there - as I see they not related with your (and my) problem. It's just IOS notifications. They do not relay on anything.

Try look at device console logs when publish stream. It might be errors with H264 codec or something close to it.

I will try 5.0 soon and write about it.

I think that if you not yet get any published stream - my problem do not relate with yours. Try to check all connected with stream publishing first. Code, OWT server logs etc.

 

K-OS
Beginner
1,001 Views

It is working now. We had to change something in our code...

...and yes, our problems were not related.

Thanks for your response!

Reply