Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
59 Views

Intel XDK Webrtc Login, Intel CS for WebRTC, Unsupported Client

Hi, everyone

I am new to WebRTC issues. After a few research, i found that intel xdk has webrtc widgets.

I am changing the server address from http://180.153.223.233:8095/webrtc to http://192.168.1.13:8095, ; and when I run "node peerserver.js" and intel xdk application peerserver.js says "Unsuppoted client. Client version:1.5" 

gap.websocket.js is 1.5 but Intel CS for WebRTC version is 3.0
function Gab(loginInfo){

  var serverAddress = loginInfo.host;
  var token = loginInfo.token;

  var clientType='Web';
  var clientVersion='1.5';
...................

Do you know how to solve it or any link to download for compatible versions?

Best Regards

 

Tags (2)
0 Kudos
9 Replies
Highlighted
Beginner
59 Views

Anybody?

0 Kudos
Highlighted
59 Views

The Intel WebRTC SDK embedded in XDK is v1.5. Please run PeerServer 1.5 instead of 3.0 if you really want that.

Thanks!

0 Kudos
Highlighted
Beginner
59 Views

Thank you for replying,

but where exatly in xdk?

0 Kudos
Highlighted
Beginner
59 Views

CHUNBO i couldnt find peerserver.js 1.5 version embedded one on Intel XDK

0 Kudos
Highlighted
59 Views

Hi Akin,

The v1.5 version is legacy now. I think you've already received the right package...

Thanks!

0 Kudos
Highlighted
Beginner
59 Views

ss2.jpg

0 Kudos
Highlighted
59 Views

Hi Akin,

You cannot use the v1.5 client with Peer Server v3.0. The team are still working on the latest integration. Stay tuned!

Thanks!

0 Kudos
Highlighted
Beginner
59 Views

ok , and I am still waiting for your team :) thanks

0 Kudos
Highlighted
59 Views

Sure. We'll post a sticky item when it's ready!

0 Kudos