Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
1136 Discussions

Kinda urgent, firefox no longer compatible.

Stephen_-_
New Contributor I
221 Views

When you try to subscribe to a stream, the following error shows in console "ICE failed, add a STUN server and see about:webrtc for more details"

 

I don't believe a STUN server is required, as it is not using P2P, the server has a direct connection to the internet and is acting as a forwarder.

It was caused by this as printed in the release notes https://www.mozilla.org/en-US/firefox/74.0/releasenotes/

Firefox now provides better privacy for your web voice and video calls through support for mDNS ICE by cloaking your computer’s IP address with a random ID in certain WebRTC scenarios.

I have had a user disable a firefox flag and be able to continue as normal, however I didn't write down what flag he said works... but there is a flag!

 

Obviously this isn't acceptable... Is there any advice on a fix for this issue with an upcoming new release? To not have default firefox compatibility is a big disadvantage.

0 Kudos
2 Replies
Stephen_-_
New Contributor I
221 Views

Okay the temporary fix firefox users can do, is go to about:config in the address bar.

Search for "obfuscate",

either add the hostname to the "media.peerconnection.ice.obfuscate_host_addresses.whitelist" flag, or set media.peerconnection.ice.obfuscate_host_addresses to false.

Other webrtc sites don't seem to be having this issue.

Stephen_-_
New Contributor I
221 Views

Furthermore, changing 

conference = new Owt.Conference.ConferenceClient();

to

conference = new Owt.Conference.ConferenceClient({ 
    iceServers:  [{
    urls: "stun:stun.l.google.com:19302"
    }]
});

Does not change the behaviour or the error message complaining for a stun server. Am I correct that that is a valid stun server address at the moment? Have I put it in right?

Reply