Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
1147 Discussions

NAT environment not working all the time

Naresh_R_1
New Contributor I
2,015 Views

Dear Team,

We have installed Intel MCUv5 CentOS 7.2 Software accelerated in a Natted Environment  in a single machine

Type of NAT: Static

No of Network Interfaces: 1 

No of ports opened: TCP: 443 , 80, 3000-3004, 8080, 27017 , 5672,  UDP Range: 49152-65535

1. when we configure public IP under webrtc_agent.toml file stream from local network wont publish at all, but when we changed it to default[] it works from local network with out any issues

from the above scenario(1) from public network stream sometimes get publishes but most of time it wont publish, we also configure stun/turn servers also on public network directly with no restrictions

2. what ever the configuration we give in webrtc_agent/agent.toml server just takes and it is not working from public network

Please let us know the best configuration which works under NAT Environment

Thanks

Naresh

 

 

 

0 Kudos
33 Replies
Naresh_R_1
New Contributor I
821 Views

Hi Qiujiao,

That solution which you have provided is for MCU version 3.5, we are using 3.3 version since there are multiple issues with 3.5 like port release issues, ice issues and room gets fails when there is a traffic on single room.

Any solution for version 3.3?

Thanks

Naresh

0 Kudos
Qiujiao_W_Intel
Employee
821 Views

For 3.3, currently no solution for this case. We will have a new release recently which will fix ice and room gets fail issue, for port issue, we are working on it.

0 Kudos
Naresh_R_1
New Contributor I
821 Views

Hi Qiujiao,

Thanks for the update.

When can we expect new release with the issues fixed?

Thanks

Naresh

0 Kudos
Qiujiao_W_Intel
Employee
821 Views

Hi, Naresh, version 3.5.2 has been released, please try this version. NAT issue has been fixed in this version, please check if it works well in your environment.

0 Kudos
Naresh_R_1
New Contributor I
821 Views

Hi Qiujiao,

Thanks for the update. do we still have to launch multiple webrtc_agents for nat issue with this release.

Thanks

Naresh

0 Kudos
Naresh_R_1
New Contributor I
821 Views

 

Hi Qiujiao,

I have installed v 3.5.2 in Nat Environment as mentioned in this topic first post, with out launching multiple webrtc_agents.and pointing public IP under [webrtc] as below

network_interfaces = [{name = "ens160", replaced_ip_address = "203.196.151.152"}]  # default: []

It is working from internet users connecting through public IP. but from Lan we get error ice procedure failed

Thanks

Naresh

 

Also as you mentioned below steps for Nat Issue

1. set ipsp to "internal" in Release-v3.5.1/webrtc-agent/agent.toml and other internal network settings and launch webrtc agent 1

2. copy webrtc-agent, bin, package.json in Release-3.5.1 to a new folder test, and then set ipsp to "external" in test/webrtc-agent/agent.toml  and other external network settings, then launch webrtc agent 2

3. user 1 in internal network call createToken with setting isp to "internal" in preference option and then join room

4. user 2 in external network call createToken with setting isp to "external" in preference option and then join room

Then internal and external network should work well, you can deploy 2 portal with the same isps setting as webrtc agent

Where do we set preference option what will be the configuration under portal and webrtc agents under ISP

Thanks

Naresh

 

0 Kudos
Qiujiao_W_Intel
Employee
821 Views

For users, before they join room, they need to call createToken API to get token, please refer to this API js sdk document, you can specify internal isp for internal users when calling createToken, then internal users connection will be scheduled to internal isp portal and webrtc agent. For external users, please specify external isp info in createToken and their connection will be scheduled to external isp portal and webrtc agent

0 Kudos
Naresh_R_1
New Contributor I
821 Views

Hi Qiujiao,

I can specify in webrtc_agent.toml file like the below? and ask client to to call this internal or external create token API?


[capacity]
#The ISP list this agent tends to handle
isps = ["internal"] #default: [], which means all ISPs.
#The region list this agent tends to handle
regions = [] #default: [], which means all regions.

Also do we have to launch multiple portals??

 

Thanks

Naresh

 

0 Kudos
Qiujiao_W_Intel
Employee
821 Views

Yes, you need specify internal in both webrtc and portal toml files, so you need launch at least 2 webrtc agents, one for internal connection, one for external connection; 2 portal, one for internal, one for external. Then internal clients call createToken with internal isp option, and external clients call createToken with external isp option, then both external and internal clients can connect to MCU.

0 Kudos
Naresh_R_1
New Contributor I
821 Views

Hi Qiujiao,

How can we launch 2 portals in a single machine? the solution seems to be only for cluster deployment. 

For customers with minimum number of calls cluster deployment will not be ideal solution. we need mcu to be run in a single standalone server with all components together

Thanks

Naresh

0 Kudos
Qiujiao_W_Intel
Employee
821 Views

You can copy portal folder and package.json file to a different folder in the same machine just like running 2 webrtc agents in one single standalone server

0 Kudos
Naresh_R_1
New Contributor I
821 Views

Confused..... ;) i have to use separate hostname for both portals?

Cant Nat issue fixed with standalone service with out launching multiple agents 

Thanks

Naresh

0 Kudos
Qiujiao_W_Intel
Employee
821 Views

Naresh, this is a workaround tor current release if you want both internal and external clients connect to MCU in NAT, we will fix it with standalone service in the future release.

0 Kudos
Reply