Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I

Not able to publish video

Hi Chunbo,

We are facing new issue from one of the network provider, when we are trying to establish connection from that network we are not able to publish video regardless of firewall, with out firewall and from open network.

MCU is on direct static ip with out Firewall

Mode: Hybrid Conference Mode

Here is an extract of the server side log:

2016-05-12 09:18:58,418  - DEBUG: WebRtcConnection - Setting VIDEO CANDIDATE
PROCESS CAND { type: 'candidate',
  candidate:
   { sdpMLineIndex: 0,
     sdpMid: 'audio',
     candidate: 'a=candidate:3078610798 1 udp 1686052607 124.123.184.30 51949 typ srflx raddr 192.168.1.6 rport 51949 generation 0 ufrag QFp1ZRpCo6o5F0Mm' } }
2016-05-12 09:18:58,419  - DEBUG: WebRtcConnection - Adding remote Candidate a=candidate:3078610798 1 udp 1686052607 124.123.184.30 51949 typ srflx raddr 192.168.1.6 rport 51949 generation 0 ufrag QFp1ZRpCo6o5F0Mm, mid audio, sdpMLine 0
2016-05-12 09:18:58,419  - DEBUG: WebRtcConnection - Setting VIDEO CANDIDATE
2016-05-12 09:18:59,203  - INFO: NiceConnection - video - NICE State Changing from 1 to 2 0x31490e0
2016-05-12 09:19:01.347  - DEBUG: ErizoJS - KeepAlive from ErizoController
2016-05-12 09:19:06.349  - DEBUG: ErizoJS - KeepAlive from ErizoController
2016-05-12 09:19:11.350  - DEBUG: ErizoJS - KeepAlive from ErizoController

 

After the nice state change, transport is not getting update.

And these logs are from the C++ execuable of webrtc_mcu, so we are not able to debug it.

Outcome of our debugging on the client side:

1. After the ice candidate gethering, the iceconnection state change is not happening.

2. Add stream function is not properly getting executed and the create offer function is failing, this is what leading to the failure in ice connection state change.

PS: client side log is attached

Please advise on this.

We are facing this issue with only one particular internet service provider.

Thanks & Regrads,

Naresh P

Tags (2)
0 Kudos
8 Replies
Highlighted

Hi Naresh,

Hi Naresh,

Could you give us more information about this "network provider"? And where is the client log?

Thanks!

0 Kudos
Highlighted
New Contributor I

Hi Chunbo,

Hi Chunbo,

Attached is Browser and webrtc internals logs

Regards

Naresh

0 Kudos
Highlighted

Could you give us more

Could you give us more information about this "network provider"?

Thanks!

0 Kudos
Highlighted
New Contributor I

Hi Lei,

Hi Lei,

We based on India, we are now facing the above said issue with multiple ISP providers, we have checked with servers hosting is different locations but the issue still exists

If you can check the logs attached above and  find any issues.

Also we can provide the access of the client machine if you can check with the issue

 

Thanks

Naresh

0 Kudos
Highlighted
New Contributor I

Hi Lei,

Hi Lei,

But remaining solutions like Licode, Intel P2P is working fine with the same network

Thanks

Naresh

0 Kudos
Highlighted
Employee

Which Intel CS for WebRTC

Which Intel CS for WebRTC version are you using?

0 Kudos
Highlighted
New Contributor I

Hi Lei,

Hi Lei,

We have used all the Intel CS WebRTC versions v3.1 , v3.1.1 , v3.2. MCU is deployed on on direct Public IP and also we used Coturn as a Turn Server and all the ports are opened on both MCU and Turn server

Thanks

Naresh

0 Kudos
Highlighted
Employee

So can you please share the

So can you please share the error log on the latest v3.2 version?

0 Kudos