Intel® Collaboration Suite for WebRTC
Community support and discussions on the Intel® Collaboration Suite for WebRTC (Intel® CS for WebRTC).
Announcements
Intel Customer Support will be observing the Martin Luther King holiday on Monday, Jan. 17, and will return on Tues. Jan. 18.
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

Recorder in v.2.8

Bryan_A_
Beginner
110 Views

Hello !

My question about recorder... I try recording specific stream in room without mixing and i got error ("Error in start recording:"), when i change mixing in room to enable, try record again and it work.
But i dont need mixing in room, this options for conference and it require more a CPU resources.
I need room for p2p videochat with recording options.
Well, how to get recording in room without mixing ? :)

Thanks in advance for answers

 

0 Kudos
5 Replies
Chunbo_H_Intel1
Employee
110 Views

Hi Bryan,

Are you using the v2.8.1? Please follow the information in our release note:

"3. MCUroomrecording may not always work whenchoosingforward room mode, unless the following workaround is used:

a. Set the value of key config.erizoAgent.maxProcesses in etc/woogeen_config.js to 1.

b. Set the value of key config.erizoAgent.prerunProcesses in etc/woogeen_config.js to 1. "

Thanks!

Bryan_A_
Beginner
110 Views

Hi CHUNMO!

Thanks, its work.

Yes, version i am use - 2.8.1.

"a. Set the value of key config.erizoAgent.maxProcesses in etc/woogeen_config.js to 1.
b. Set the value of key config.erizoAgent.prerunProcesses in etc/woogeen_config.js to 1."

I set this options both, and record in unmixing room work, but avr on recording better then defaults options and publish stream to mixing room with option unmix: true

config.erizoAgent.prerunProcesses - equals or lower config.erizoAgent.maxProcesses, ok!

Tests:
config.erizoAgent.prerunProcesses = 1 and config.erizoAgent.maxProcesses = 4, room mixing:false  - got Error again (Error in start recording: error)
config.erizoAgent.prerunProcesses = 1 and config.erizoAgent.maxProcesses = 1, room mixing:false - work, recording one hd1080p stream: 90-100% avr one core
(default) config.erizoAgent.prerunProcesses = 2 and config.erizoAgent.maxProcesses = 13 room mixing:true and publish with opt unmix:true - work, recording one hd1080p stream: 40-50% avr one core.

 

 

Chunbo_H_Intel1
Employee
110 Views

OK. Cool. Glad see it work.

Bryan_A_
Beginner
110 Views

Hello again!

Next question about audio codec, audio quality in recording and options for recording only audio stream  :)

Audio quality in out record file is bad, example: 1 room, 1 stream - subscribe this stream from web - audio quality is perfect, then in this connection, start recorder on this stream and get file with bad audio quality.
Audio codec info from file record: PCM  U-law
I think, audio codec in web connection: Opus
Where i can choose audio codec in recorder ?

And about option for recorder, record only audio from stream with video and audio ? its possible ?

Chunbo_H_Intel1
Employee
110 Views

Currently, the audio codec in recorder defaults to PCMU, and audio-only recorder is not supported yet as well. But we are continuously working on improving this feature.

Thanks for the feedback.

Reply