Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
33 Views

SIP High Profile Codec not supporting

Hi Chunbo,

We have installed MCU Version 3.2 with hardware accelerated and installed MSS, we have also configured kamailio and configured SIP connectivity

we configured the same in sip endpoint and tried calling with high profile video codec, only audio works video doesnt works

tested with baseline codecs it works well

Does new mcu supports High Profile Video codec?

Thanks

Naresh

Tags (2)
0 Kudos
12 Replies
Highlighted
Employee
33 Views

Hi, Naresh

Actually MSS and MCU media pipeline support both baseline and high profile streams. But now MCU set baseline only in the SDP when negotiate with SIP endpoint. If your SDP endpoint strictly follow the SDP video codec suggestion, then it may fail. We will test and add high profile in MCU SDP later.

Best wishes,

Zhai Lei

0 Kudos
Highlighted
New Contributor I
33 Views

Hi Lei,

Thank you for your update. 

Also we noticed when MCU room with sip connectivity is registered with sip account its getting registered and sip call everything works fine.

Once we unregister the sip user from the room its not getting updated in sip server and its still online and next time onwards we are forced to create new user.

but it works fine with sip soft client 

we used kamailio sip server

Thanks

Naresh

0 Kudos
Highlighted
New Contributor I
33 Views

Hi Lei,

Noticed that when we restart MCU the sip users are not getting unregister in sip server and next time when we start server sip call not getting through

Thanks

Naresh

0 Kudos
Highlighted
Employee
33 Views

Thanks for reporting this issue. We will double check and try to reproduce it soon.

0 Kudos
Highlighted
Employee
33 Views

We can't reproduce your issue. When MCU restart, the MCU room SIP user can login successfully to Kamalio server, even haven't done explicit log out action when stop MCU server.

Can you please explain more on the following words? You mean MCU room's sip representative haven't log out during MCU shutdown and cause the log in fail when next time MCU start. But why soft sip client can work with it? Seems none of business with client side.

"

Once we unregister the sip user from the room its not getting updated in sip server and its still online and next time onwards we are forced to create new user.

but it works fine with sip soft client 

"

0 Kudos
Highlighted
New Contributor I
33 Views

Hi Lei,

you can check with the following scenario

1. Register sip user in MCU and then stop MCU server or un-register sip again

check in Kamailio the sip user will be still active or online

 

Problem is sip users not getting unregister in kamailio even when we disable sip connectivity in console

Thanks

Naresh

0 Kudos
Highlighted
New Contributor I
33 Views

Since its not getting unregister from kamailio and when we try again registering with same sip account its getting register but video call not getting initiated

Thanks

Naresh

0 Kudos
Highlighted
Employee
33 Views

Actually we did the exact steps you mentioned, but still can make the SIP call into room. Can you please share your MCU logs after these steps?

0 Kudos
Highlighted
New Contributor I
33 Views

Hi Lei,

Issue exactly is not able unregister sip account immediatly from MCU. when we disable sip connectivity the user is still online in kamailio. 

we are kamailio version 4.2, whuch version of kamailio you recommend

Thanks

Naresh

0 Kudos
Highlighted
Employee
33 Views

Hi, Naresh

We use 4.4.1. How about you try that version?

Best wishes,

Zhai Lei

0 Kudos
Highlighted
Beginner
33 Views

Hi Lei,

 

I am also facing same issue with sip registration . let me explain in breif i am using kamailio 4.4 

1 ) i created one user in kamailio and register in MCU (It was registering successfully and showing in kamailio online users list .

2) when i make call SIP call to MCU it was working good

3) when my sip call disconnected unexpectedly due to connection loss or end point hangup the video in the MCU remains same when i end the call in the MCU and join again also it was remaining same untill i restart MCU

4 ) when i restart MCU the sip call in the same MCU room room not working with same sip ID which i used before . But in kamailio active users list it was showing active 

5 ) In this case again i need to create new sip account in kamailio and need to configure to my MCU room then it was working 

 

please solve this issue or keep register and unregister buttons for sip configuration or please provide us the API nuve for sip which helps lot 

 

 

 

0 Kudos
Highlighted
Employee
33 Views

Hi, ANIL

I think there are two problems here.

One is the unexpected disconnect SIP call (not explicit hang up or close) will cause the last frame always remains in MCU room mix stream. This is the known issue, we will try to fix this in following releases.

The other is the MCU SIP room user can't double registration. We can't reproduce this issue, appreciate your assistance on further identifying it in advance. To workaround this issue, we can unregister the SIP room user from the SIP server during the MCU server exit. However, think about that in case the MCU server exits abnormally, without executing the clean up procedure, the problem will still be exist. So we expect the SIP server can tolerant such relogin. And it do works in our environment. I will send you our Kamailio log for these double register actions. If you found anything different with yours, then please also upload yours, that would be very helpful. Thanks!

Best wishes,

Zhai Lei

0 Kudos