Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
43 Views

Super Service Rooms Not Working

Hi,

After configuring rooms in super service ID we are not able to enter with that room ID

and also when i change the resolution in sample service ID. the Resolution doesn't change.

Is there any other configuration for that to work

In Sample service i am not able to check 2 way conference. its creating another instance.. the video is not subscribing is there any configuration.

please find the logLOG

This appears to be Chrome

script2.js:170 localStream: undefined
script2.js:182 start publish
script2.js:190 publish end
script2.js:184 published
woogeen.sdk.js:8 INFO: stream published: 1zQvONUO0ShUtH8cUYu2
woogeen.sdk.js:8 INFO: stream added: 1zQvONUO0ShUtH8cUYu2
woogeen.sdk.js:8 INFO: stream 1zQvONUO0ShUtH8cUYu2 is from me; will not be subscribed.

and also in sample service how we need to check through IE. as i cannot find IE plugin

Do we need to install any plugin as i am not able to login through IE

 

Thanks

Naresh

Tags (2)
0 Kudos
3 Replies
Highlighted
43 Views

Hi Naresh,

If you want to use rooms in super service, then you need first to use the super service key and id to initialize your Nuve  API in the web application. Did you do that?

And, I just wonder how you changed the resolution in sample service ID. By API, or our sample management UI? Do remember to 'apply' the changes to the room before it takes effect.

We do have IE plugin for WebRTC in the release package. Please try to locate it from your download.

0 Kudos
Highlighted
New Contributor I
43 Views

Hi Chunbo,

Thanks very much for support

1. Yes i used super service Key and logged to web interface management console. i have created and new room and tried to login with room ID as 203.xx.xx.xx:3001/?room=55a36d83c5bba24811397137

the error is invalid token server connection failed

2. in sample service have changed the resolution and applied properly and updated. and cross checked it was updated

but when i login to that room id and checked the video properties it was unchanged. 

3. Another issue i have disabled $
config.erizoController.mixer = false;  as server cpu resources are using high

when i test conference the video is not subscribing, but when i enabled the mixer the video is subscribed and published 

is there any other configuration to be made

 

4. Thanks for the IE plugin it worked perfect. cheers

 

Thanks

Naresh

 

 

 

 

 

0 Kudos
Highlighted
43 Views

1. In this case, you need to update the service key and ID in your web server (basic example) with the line started with "N.API.init..."

2. Did you get a "Update Room Success" message as the final update popup?

"but when i login to that room id and checked the video properties it was unchanged. ": How did you login? Does it mean to connect to the room with a browser?

And what's more, the current management UI is ONLY a sample, just like the basic example provided. It'd better you guys develop your own web applications based on our examples and SDKs.

3. Refer to the script2.js in the basic example, and you will find that if you do not specify anything in the url, the mix stream shall be subscribed. Since you disabled the mix engine, there will be nothing subscribed from server. The Conference Server User Guide provides more details regarding those options, which might be helpful to you.

4. You're welcome!

Thanks!

0 Kudos