Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
3 Views

TCP transport listen in port range bind error: Address already in use

webrtc_agent port number from 10000 to 30000

when join room, the PC/browser client can publish local stream, but cannot subscribe stream frequence, there's no any error/warning on client side, 

The server side log:

webrtc_agent:

2019-08-05 21:45:11.013  - INFO: WorkingNode - pid: 9482
2019-08-05 21:45:11.015  - INFO: WorkingNode - Connecting to rabbitMQ server...
2019-08-05 21:45:11.030  - INFO: AmqpClient - Connecting to rabbitMQ server OK, options: { host: 'localhost', port: 5672 }
2019-08-05 21:45:11.050  - INFO: WorkingNode - webrtc-4bd2d32fe2d280510e1c@192.168.1.179_74 as rpc server ready
2019-08-05 21:45:11.052  - INFO: WorkingNode - webrtc-4bd2d32fe2d280510e1c@192.168.1.179_74 as monitor ready
2019-08-05 22:06:12,693  - WARN: owt.RawTransport - TCP transport listen in port range bind error: Address already in use
2019-08-05 22:06:12,698  - WARN: owt.RawTransport - TCP transport listen in port range bind error: Address already in use

 

video_agent:

2019-08-05 21:31:28.672  - INFO: WorkingNode - pid: 5592
2019-08-05 21:31:28.674  - INFO: WorkingNode - Connecting to rabbitMQ server...
2019-08-05 21:31:28.688  - INFO: AmqpClient - Connecting to rabbitMQ server OK, options: { host: 'localhost', port: 5672 }
2019-08-05 21:31:28.705  - INFO: WorkingNode - video-618655efa369d6f4c23f@192.168.1.179_53 as rpc server ready
2019-08-05 21:31:28.708  - INFO: WorkingNode - video-618655efa369d6f4c23f@192.168.1.179_53 as monitor ready
2019-08-05 21:33:12,011  - INFO: mcu.media.VideoMixer - Init maxInput(16), rootSize(1280, 720), bgColor(16, 128, 128)
2019-08-05 21:33:14,451  - ERROR: owt.RawTransport - Error establishing the TCP connection: Connection refused
2019-08-05 21:33:39,661  - ERROR: owt.RawTransport - Error establishing the TCP connection: Connection refused
2019-08-05 21:33:51,517  - ERROR: owt.RawTransport - Error establishing the TCP connection: Connection refused
2019-08-05 21:36:22,324  - ERROR: owt.RawTransport - Error establishing the TCP connection: Connection refused
2019-08-05 21:43:43,297  - ERROR: owt.RawTransport - Error establishing the TCP connection: Connection refused
2019-08-05 21:45:11,404  - ERROR: owt.RawTransport - Error establishing the TCP connection: Connection refused
2019-08-05 21:52:27,153  - ERROR: owt.RawTransport - Error establishing the TCP connection: Connection refused
2019-08-05 22:06:12,700  - ERROR: owt.RawTransport - Error establishing the TCP connection: Connection refused

 

How to debug this problem,

 

Thanks

 

Tags (2)
0 Kudos